summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Sinclair2017-01-08 16:52:12 -0500
committerAdrian Sinclair2017-01-08 16:52:12 -0500
commit41b161dbd2fda545d89fae74e7218f4fac06c18a (patch)
tree72a6a1fb363fe6cde9e1de132e962fa2880bb23a
downloadaur-41b161dbd2fda545d89fae74e7218f4fac06c18a.tar.gz
create package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cae94adb2736
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eslint-plugin-promise
+ pkgdesc = Enforce best practices for JavaScript promises
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = https://github.com/xjamundx/eslint-plugin-promise
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = eslint-plugin-promise-3.4.0.tgz
+ source = http://registry.npmjs.org/eslint-plugin-promise/-/eslint-plugin-promise-3.4.0.tgz
+ md5sums = SKIP
+
+pkgname = eslint-plugin-promise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..361e903b25bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Adrian Sinclair <adrian@transloadit.com>
+
+pkgname=eslint-plugin-promise
+pkgver=3.4.0
+pkgrel=1
+pkgdesc='Enforce best practices for JavaScript promises'
+arch=('any')
+url='https://github.com/xjamundx/eslint-plugin-promise'
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+md5sums=('SKIP')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
+ rm -r "$pkgdir"/usr/etc
+
+ # Fix permissions
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s ../../../lib/node_modules/$pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}