summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2017-11-04 21:47:22 -0400
committeryhfudev2017-11-04 21:47:22 -0400
commitc855753ae3cbe048c35969d82d340045a185290e (patch)
tree560dae9ea5eef1b24caf8134a01a84e3f5f1017d
downloadaur-c855753ae3cbe048c35969d82d340045a185290e.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dedab76cee25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Nov 5 01:44:21 UTC 2017
+pkgbase = esniper-git
+ pkgdesc = A simple, lightweight tool for sniping eBay auctions.
+ pkgver = r413.7771d53
+ pkgrel = 1
+ url = https://github.com/yhfudev/esniper.git
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ license = BSD
+ depends = curl
+ depends = openssl
+ source = esniper-git::git+https://github.com/yhfudev/esniper.git
+ md5sums = SKIP
+
+pkgname = esniper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e7ff08994e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Yunhui Fu <yhfudev@gmail.com>
+pkgname=esniper-git
+pkgver=r413.7771d53
+pkgrel=1
+pkgdesc="A simple, lightweight tool for sniping eBay auctions."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'arm')
+url="https://github.com/yhfudev/esniper.git"
+license=('BSD')
+depends=('curl' 'openssl')
+source=(
+ "${pkgname}::git+https://github.com/yhfudev/esniper.git"
+ )
+md5sums=('SKIP')
+
+pkgver_git() {
+ cd "${srcdir}/${pkgname}"
+ #local ver="$(git show | grep commit | awk '{print $2}' )"
+ #printf "r%s" "${ver//[[:alpha:]]}"
+ #echo ${ver:0:7}
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+pkgver() {
+ pkgver_git
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -D -m755 frontends/snipe "${pkgdir}/usr/bin/snipe"
+}