summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Henrie2022-12-23 00:40:22 -0700
committerAlex Henrie2022-12-23 00:40:22 -0700
commit43bc5a80991e8f57099b48785914083b550ec7d4 (patch)
tree7213c06cac5390a6d459b25e3dc749742bd02ee1
parent071f3818c36374a6ae5ef40fbf129a54a536d67b (diff)
downloadaur-43bc5a80991e8f57099b48785914083b550ec7d4.tar.gz
Update and improve usage instructions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--esp-idf.install24
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c34ab69c771e..bc70f3b34dab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = esp-idf
pkgdesc = Espressif IoT Development Framework. Official development framework for ESP32.
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/espressif/esp-idf
install = esp-idf.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index f29e4ef96807..444122872713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
pkgname=esp-idf
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Espressif IoT Development Framework. Official development framework for ESP32."
arch=('i686' 'x86_64' 'aarch' 'aarch64' 'armv7h')
url="https://github.com/espressif/esp-idf"
diff --git a/esp-idf.install b/esp-idf.install
index ee5e96be4d87..fef179b32f25 100644
--- a/esp-idf.install
+++ b/esp-idf.install
@@ -1,7 +1,21 @@
post_install() {
- cat <<HERE
-Set ESPIDF variable to /opt/esp-idf in your profile
-e. g. like this:
- echo 'export ESPIDF=/opt/esp-idf' >>~/.profile
-HERE
+ echo -e "\e[1;33m" # yellow
+
+ echo 'To use ESP-IDF:'
+ echo
+ echo '1. Run /opt/esp-idf/install.sh to install ESP-IDF to ~/.espressif.'
+ echo ' You only have to do this once after installing or upgrading'
+ echo ' the esp-idf package.'
+ echo
+ echo '2. Run `source /opt/esp-idf/export.sh` to add idf.py and idf_tools.py'
+ echo ' to your current PATH. You will have to do this in every terminal'
+ echo ' where you want to use ESP-IDF. Alternatively, you can add'
+ echo ' "source /opt/esp-idf/export.sh" to ~/.bashrc or the equivalent for'
+ echo ' your shell to load ESP-IDF automatically in all terminals.'
+
+ echo -e "\e[1;0m" # default
+}
+
+post_upgrade() {
+ post_install
}