summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Bazley2017-07-08 00:39:09 +0100
committerSam Bazley2017-07-08 00:39:09 +0100
commit4aaa5fba409c0fe136c75c65a5c9ce9bc007ae74 (patch)
tree006f217fe7b9890fc28a2f3fe6fc8bccbe2c7f56
downloadaur-4aaa5fba409c0fe136c75c65a5c9ce9bc007ae74.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--Makefile.patch22
-rw-r--r--PKGBUILD49
-rw-r--r--blinky_Makefile.patch20
-rw-r--r--crosstool-config-overrides.patch9
-rw-r--r--esp-open-sdk-git.sh1
6 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049dae5b0162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = esp-open-sdk-git
+ pkgdesc = Free and open (as much as possible) integrated SDK for ESP8266 chips
+ pkgver = 20170528090946
+ pkgrel = 1
+ url = https://github.com/pfalcon/esp-open-sdk
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = gperf
+ makedepends = help2man
+ depends = python
+ depends = python2
+ depends = python-pyserial
+ depends = python2-pyserial
+ depends = esptool
+ provides = esp-open-sdk
+ conflicts = esp-open-sdk
+ options = !strip
+ source = git+https://github.com/pfalcon/esp-open-sdk.git
+ md5sums = SKIP
+
+pkgname = esp-open-sdk-git
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..1cf566bc7cf3
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile.old 2017-02-09 22:44:09.998928546 +0000
++++ Makefile 2017-02-09 22:44:35.886338414 +0000
+@@ -72,11 +72,6 @@
+
+
+ all: esptool libcirom standalone sdk sdk_patch $(TOOLCHAIN)/xtensa-lx106-elf/sysroot/usr/lib/libhal.a $(TOOLCHAIN)/bin/xtensa-lx106-elf-gcc lwip
+- @echo
+- @echo "Xtensa toolchain is built, to use it:"
+- @echo
+- @echo 'export PATH=$(TOOLCHAIN)/bin:$$PATH'
+- @echo
+ ifneq ($(STANDALONE),y)
+ @echo "Espressif ESP8266 SDK is installed. Toolchain contains only Open Source components"
+ @echo "To link external proprietary libraries add:"
+@@ -118,7 +113,6 @@
+
+
+ esptool: toolchain
+- cp esptool/esptool.py $(TOOLCHAIN)/bin/
+
+ toolchain: $(TOOLCHAIN)/bin/xtensa-lx106-elf-gcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a74308d8ac4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+#Maintainer: Sam Bazley <samb1999@hotmail.co.uk>
+pkgname=esp-open-sdk-git
+pkgver=20170528090946
+pkgrel=1
+pkgdesc="Free and open (as much as possible) integrated SDK for ESP8266 chips"
+arch=("i686" "x86_64")
+url="https://github.com/pfalcon/esp-open-sdk"
+makedepends=("git" "gperf" "help2man")
+depends=("python" "python2" "python-pyserial" "python2-pyserial" "esptool")
+provides=("esp-open-sdk")
+conflicts=("esp-open-sdk")
+options=("!strip")
+
+source=("git+https://github.com/pfalcon/esp-open-sdk.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd esp-open-sdk
+ git show -s --format=%ci HEAD | cut -d ' ' -f1-2 | sed -r 's/[^0-9]//g'
+}
+
+prepare() {
+ cd "$srcdir"/esp-open-sdk
+ git submodule init
+ git submodule deinit esptool
+ git submodule update
+ patch Makefile < "$startdir"/Makefile.patch
+ patch crosstool-config-overrides \
+ < "$startdir"/crosstool-config-overrides.patch
+ patch examples/blinky/Makefile < "$startdir"/blinky_Makefile.patch
+}
+
+build() {
+ cd "$srcdir"/esp-open-sdk
+ CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS= LD_LIBRARY_PATH= make
+}
+
+package() {
+ cd "$startdir"
+ mkdir -p "$pkgdir"/etc/profile.d
+ install -m755 esp-open-sdk-git.sh "$pkgdir"/etc/profile.d
+
+ mkdir -p "$pkgdir"/opt/esp-open-sdk
+ cd "$srcdir"/esp-open-sdk/
+ cp -dpr --no-preserve=ownership sdk "$pkgdir"/opt/esp-open-sdk
+ cp -dpr --no-preserve=ownership \
+ ESP8266_NONOS_SDK_V2.0.0_16_08_10 "$pkgdir"/opt/esp-open-sdk
+ cp -dpr --no-preserve=ownership xtensa-lx106-elf "$pkgdir"/opt/esp-open-sdk
+}
diff --git a/blinky_Makefile.patch b/blinky_Makefile.patch
new file mode 100644
index 000000000000..a0dd04c13b4c
--- /dev/null
+++ b/blinky_Makefile.patch
@@ -0,0 +1,20 @@
+--- Makefile.old 2017-02-08 21:50:27.971401267 +0000
++++ Makefile 2017-02-08 21:51:25.598659966 +0000
+@@ -4,14 +4,14 @@
+ LDFLAGS = -Teagle.app.v6.ld
+
+ blinky-0x00000.bin: blinky
+- esptool.py elf2image $^
++ esptool elf2image $^
+
+ blinky: blinky.o
+
+ blinky.o: blinky.c
+
+ flash: blinky-0x00000.bin
+- esptool.py write_flash 0 blinky-0x00000.bin 0x40000 blinky-0x40000.bin
++ esptool write_flash 0 blinky-0x00000.bin 0x10000 blinky-0x10000.bin
+
+ clean:
+- rm -f blinky blinky.o blinky-0x00000.bin blinky-0x40000.bin
++ rm -f blinky blinky.o blinky-0x00000.bin blinky-0x10000.bin
diff --git a/crosstool-config-overrides.patch b/crosstool-config-overrides.patch
new file mode 100644
index 000000000000..91d83c55bcde
--- /dev/null
+++ b/crosstool-config-overrides.patch
@@ -0,0 +1,9 @@
+--- crosstool-config-overrides.old 2017-02-09 20:31:35.367784868 +0000
++++ crosstool-config-overrides 2017-02-09 20:31:40.017802432 +0000
+@@ -1,5 +1,5 @@
+ # Building static toolchain causes problems on some distros which
+ # by default don't install static libs for all required dependencies
+-#CT_STATIC_TOOLCHAIN=y
++CT_STATIC_TOOLCHAIN=y
+ CT_LIBC_NEWLIB_ENABLE_TARGET_OPTSPACE=y
+
diff --git a/esp-open-sdk-git.sh b/esp-open-sdk-git.sh
new file mode 100644
index 000000000000..c56f0fcecf4d
--- /dev/null
+++ b/esp-open-sdk-git.sh
@@ -0,0 +1 @@
+export PATH=/opt/esp-open-sdk/xtensa-lx106-elf/bin:$PATH