summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-03 18:23:41 +0100
committerCarl Smedstad2024-01-03 18:27:10 +0100
commitcb56a3c77f9d4d98c875ebfce649eba7d2895169 (patch)
treed373919d4511bb75adc43170fd2148bbdebc1989
parent17d14ac5f4c9f8d166d1edd669a037c46d1684e3 (diff)
downloadaur-cb56a3c77f9d4d98c875ebfce649eba7d2895169.tar.gz
Publish version 2.2.1-1
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD90
3 files changed, 76 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35b583f5db61..a87b2579ead8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = espanso
pkgdesc = Cross-platform Text Expander written in Rust
- pkgver = 2.1.8
+ pkgver = 2.2.1
pkgrel = 1
- url = https://espanso.org/
+ url = https://github.com/espanso/espanso
arch = x86_64
license = GPL3
makedepends = cargo
- makedepends = cargo-make
- makedepends = git
- makedepends = rust-script
+ depends = bzip2
depends = dbus
- depends = libnotify
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ depends = libxcb
depends = libxkbcommon
depends = libxtst
+ depends = openssl
+ depends = wxwidgets-common
depends = wxwidgets-gtk3
depends = xclip
depends = xdotool
options = !lto
- source = git+https://github.com/federico-terzi/espanso.git#tag=v2.1.8
- sha512sums = SKIP
+ source = espanso-2.2.1.tar.gz::https://github.com/espanso/espanso/archive/v2.2.1.tar.gz
+ sha256sums = 795663cb64c28322b667998f95910134b042be2baaace5506790f7e44ae3be91
pkgname = espanso
diff --git a/.gitignore b/.gitignore
index 3ff12018295e..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-espanso
-pkg
-src
-espanso-*.pkg.tar.zst
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index f3fd4a49ffba..36c6c98c311e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,82 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
-_pkgver=2.1.8
pkgname=espanso
-pkgver=2.1.8
+pkgver=2.2.1
pkgrel=1
pkgdesc="Cross-platform Text Expander written in Rust"
arch=(x86_64)
-url="https://espanso.org/"
-license=("GPL3")
-depends=('dbus' 'libnotify' 'libxkbcommon' 'libxtst' 'wxwidgets-gtk3' 'xclip'
- 'xdotool')
-makedepends=('cargo' 'cargo-make' 'git' 'rust-script')
-options=("!lto") # fails with LTO as of 2022-03
-source=("git+https://github.com/federico-terzi/espanso.git#tag=v${_pkgver}")
-sha512sums=('SKIP')
+url="https://github.com/espanso/espanso"
+license=(GPL3)
+depends=(
+ bzip2
+ dbus
+ gcc-libs
+ glibc
+ libx11
+ libxcb
+ libxkbcommon
+ libxtst
+ openssl
+ wxwidgets-common
+ wxwidgets-gtk3
+ xclip
+ xdotool
+)
+makedepends=(cargo)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('795663cb64c28322b667998f95910134b042be2baaace5506790f7e44ae3be91')
+options=(!lto)
+
+_archive="$pkgname-$pkgver"
prepare() {
- cd "${pkgname}"
- export CARGO_HOME="$srcdir/cargo-home"
+ cd "$_archive"
+
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --target "$CARCH-unknown-linux-gnu"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
- # don't change the original service file, as it will be embedded in the binary
- cp "${pkgname}/src/res/linux/systemd.service" "systemd.service"
- sed -i "s|{{{${pkgname}_path}}}|/usr/bin/${pkgname}|g" "systemd.service"
+ # Don't change the original service file, as it will be embedded in the
+ # binary
+ sed 's|{{{espanso_path}}}|/usr/bin/espanso|g' "$pkgname/src/res/linux/systemd.service" \
+ > espanso.service
# Icon name
- sed -i "s/Icon=icon/Icon=${pkgname}/g" "${pkgname}/src/res/linux/${pkgname}.desktop"
+ sed 's/Icon=icon/Icon=espanso/g' "$pkgname/src/res/linux/espanso.desktop" \
+ > espanso.desktop
}
build() {
- cd "${pkgname}"
- export CARGO_HOME="$srcdir/cargo-home"
+ cd "$_archive"
+
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo make --profile release build-binary
+ cargo build --frozen --release \
+ --manifest-path espanso/Cargo.toml \
+ --package espanso
+}
+
+check() {
+ cd "$_archive"
+
+ # Skip failing tests - unsure why they fail
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features -- \
+ --skip tests::ipc_multiple_clients \
+ --skip tests::test_migration::base_case \
+ --skip tests::test_migration::other_directories_case \
+ --skip tests::test_migration::all_config_parameters_case \
+ --skip tests::test_migration::form_syntax
}
package() {
- cd "${pkgname}"
- install -Dm755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin/"
- install -Dm644 systemd.service "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
- install -Dm644 "${pkgname}/src/res/linux/${pkgname}.desktop" -t \
- "${pkgdir}/usr/share/applications/"
- install -Dm644 "${pkgname}/src/res/linux/icon.png" \
- "$pkgdir/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ cd "$_archive"
+
+ install -Dm755 -t "$pkgdir/usr/bin" target/release/espanso
+ install -Dm644 -t "$pkgdir/usr/lib/systemd/user" espanso.service
+ install -Dm644 -t "$pkgdir/usr/share/applications" espanso.desktop
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.md
+ install -Dm644 espanso/src/res/linux/icon.png \
+ "$pkgdir/usr/share/pixmaps/espanso.png"
}