summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaketenjoint2019-06-16 23:23:16 +0200
committerRaketenjoint2019-06-16 23:23:16 +0200
commitc158aab5ff0c1c20091996da0fe4ff96cea03550 (patch)
treea4a530a21797ec6fab82ccc59064eb080743dfd7
downloadaur-c158aab5ff0c1c20091996da0fe4ff96cea03550.tar.gz
add ESPresSO to AUR
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD62
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e6b155a0e06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = espressomd-git
+ pkgdesc = ESPResSo is a software package for performing and analyzing Molecular Dynamics simulations.
+ pkgver = 3.4.dev.r12688.f5dade55b
+ pkgrel = 1
+ url = http://espressomd.org/wordpress/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc>=5
+ makedepends = boost>=1.67
+ makedepends = cmake>=3.4
+ makedepends = fftw>=3
+ makedepends = openmpi>=1.2
+ depends = python>=3
+ depends = python-numpy
+ depends = python-opengl
+ depends = python-sphinx>=1.6.6
+ depends = python-sphinx<2.1.0
+ depends = python-sphinxcontrib-bibtex>=0.3.5
+ depends = python-mdanalysis>=0.16
+ optdepends = cuda: Build with NVIDIA GPU support
+ optdepends = hdf5: File format to store scientific data
+ optdepends = hdf5-openmpi: File format to store scientific data (openmpi version)
+ provides = espressomd
+ conflicts = espressomd
+ source = espressomd::git+https://github.com/espressomd/espresso.git
+ md5sums = SKIP
+
+pkgname = espressomd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..953c0cdf5d42
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+espressomd*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cf860dc865c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Raketenjoint <rak.joint@mailbox.org>
+pkgname=espressomd-git
+pkgver=3.4.dev.r12688.f5dade55b
+pkgrel=1
+pkgdesc="ESPResSo is a software package for performing and analyzing Molecular Dynamics simulations."
+arch=('x86_64')
+url="http://espressomd.org/wordpress/"
+license=('GPL')
+groups=()
+depends=('python>=3'
+ 'python-numpy'
+ 'python-opengl'
+ 'python-sphinx>=1.6.6'
+ 'python-sphinx<2.1.0'
+ 'python-sphinxcontrib-bibtex>=0.3.5'
+ 'python-mdanalysis>=0.16')
+optdepends=('cuda: Build with NVIDIA GPU support'
+ 'hdf5: File format to store scientific data'
+ 'hdf5-openmpi: File format to store scientific data (openmpi version)')
+makedepends=('git'
+ 'gcc>=5'
+ 'boost>=1.67'
+ 'cmake>=3.4'
+ 'fftw>=3'
+ 'openmpi>=1.2')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://github.com/espressomd/espresso.git")
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING git SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}