summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjaco2016-01-05 01:39:43 +0100
committerjaco2016-01-05 01:39:43 +0100
commit027c6d55487abe7af66d79468f982fb0f0e305b2 (patch)
tree267b15b55f3e466777a924a1aef1196cd16ad860
downloadaur-027c6d55487abe7af66d79468f982fb0f0e305b2.tar.gz
First upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--esr-disc-patcher-qt4.desktop10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de74f792aef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Jan 4 20:12:22 UTC 2016
+pkgbase = esr-disc-patcher-qt4-git
+ pkgdesc = A tool to patch DVD disc images for the Sony PlayStation 2 game console to make them burnable and working with ESR, an app for the PlayStation 2 made to play those burned games without swapping
+ pkgver = 0.24a
+ pkgrel = 1
+ url = http://psx-scene.com/forums/f164/esr-disc-patcher-linux-mac-qt4-port-60096/
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = qt4
+ makedepends = make
+ depends = qt4
+ source = git://github.com/antipatico/esr-disc-patcher-qt4.git
+ source = esr-disc-patcher-qt4.desktop
+ md5sums = SKIP
+ md5sums = d1c13874d620685fc20388f47e345ac1
+
+pkgname = esr-disc-patcher-qt4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce74ede7f6d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: jaco <jaco[at]autistici[dot]org>
+pkgname=esr-disc-patcher-qt4-git
+pkgver=0.24a
+pkgrel=1
+pkgdesc="A tool to patch DVD disc images for the Sony PlayStation 2 game console to make them burnable and working with ESR, an app for the PlayStation 2 made to play those burned games without swapping"
+license=("GPLv3")
+url="http://psx-scene.com/forums/f164/esr-disc-patcher-linux-mac-qt4-port-60096/"
+depends=('qt4')
+makedepends=('git' 'qt4' 'make')
+arch=('any')
+source=("git://github.com/antipatico/esr-disc-patcher-qt4.git"
+ "esr-disc-patcher-qt4.desktop")
+md5sums=('SKIP'
+ 'd1c13874d620685fc20388f47e345ac1')
+
+build() {
+ cd "${srcdir}/esr-disc-patcher-qt4"
+ git checkout C++11
+ qmake-qt4 -project
+ qmake-qt4
+ make
+}
+
+package() {
+ install -Dm 644 "${srcdir}/esr-disc-patcher-qt4.desktop" "${pkgdir}/usr/share/applications/esr-disc-patcher-qt4.desktop"
+
+ cd "${srcdir}/esr-disc-patcher-qt4"
+ install -Dm 755 esr-disc-patcher-qt4 "${pkgdir}/usr/bin/esr-disc-patcher-qt4"
+ install -Dm 644 esr.png "${pkgdir}/usr/share/pixmaps/esr-disc-patcher.png"
+}
diff --git a/esr-disc-patcher-qt4.desktop b/esr-disc-patcher-qt4.desktop
new file mode 100644
index 000000000000..f2f3d5caf702
--- /dev/null
+++ b/esr-disc-patcher-qt4.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=ESR Disc Patcher
+Comment=Patch PlayStation 2 ISOs!
+Exec=/usr/bin/esr-disc-patcher-qt4
+Icon=esr-disc-patcher
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Game;
+Encoding=UTF-8