aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-03-06 19:32:15 +0100
committerGrey Christoforo2019-03-06 19:32:15 +0100
commit34f51682fd9cbc721b48c211d2ca29ddb1d9fd7e (patch)
tree421fac4519808172c7e4c19c4508fcf13d9c513b
parent271d0428f38c58353e55705771b7c6d8ea5936ac (diff)
downloadaur-34f51682fd9cbc721b48c211d2ca29ddb1d9fd7e.tar.gz
base build works
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991687b1cb0b..a259bcfb8723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = ess-epics
pkgdesc = Experimental Physics and Industrial Control System -- ESS falvor
- pkgver = 3.15.4.1
+ pkgver = 7.0.2
pkgrel = 1
url = http://www.aps.anl.gov/epics/
arch = any
license = EPICS Open License
makedepends = rpcsvc-proto
+ makedepends = tree
depends = libtirpc-compat
+ depends = tclx
+ depends = tcl
depends = aravis
depends = glibmm
depends = libtirpc
@@ -35,6 +38,8 @@ pkgbase = ess-epics
depends = boost-libs
depends = libraw1394
depends = opencv
+ provides = epics
+ conflicts = epics
source = git+https://github.com/icshwi/e3.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7a45b985a093..fc561aa89c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=ess-epics
-pkgver=3.15.4.1
+pkgver=7.0.2
pkgrel=1
pkgdesc="Experimental Physics and Industrial Control System -- ESS falvor"
arch=('any')
url="http://www.aps.anl.gov/epics/"
+provides=('epics')
+conflicts=('epics')
license=('EPICS Open License')
-makedepends=('rpcsvc-proto')
-depends=('libtirpc-compat' 'aravis' 'glibmm' 'libtirpc' 'readline' 'libxt' 'libxmu' 'libxpm' 'pcre' 'net-snmp' 're2c' 'darcs' 'python2' 'netcdf' 'hdf5' 'libpng' 'bzip2' 'libxml2' 'libxml2' 'libusb' 'libusb-compat' 'remake' 'systemd' 'linux-headers' 'mercurial' 'boost' 'boost-libs' 'libraw1394' 'opencv')
+makedepends=('rpcsvc-proto' 'tree')
+depends=('libtirpc-compat' 'tclx' 'tcl' 'aravis' 'glibmm' 'libtirpc' 'readline' 'libxt' 'libxmu' 'libxpm' 'pcre' 'net-snmp' 're2c' 'darcs' 'python2' 'netcdf' 'hdf5' 'libpng' 'bzip2' 'libxml2' 'libxml2' 'libusb' 'libusb-compat' 'remake' 'systemd' 'linux-headers' 'mercurial' 'boost' 'boost-libs' 'libraw1394' 'opencv')
source=("git+https://github.com/icshwi/e3.git")
md5sums=('SKIP')
+MAKEFLAGS="-j1" # mutithread building breaks this
+
prepare() {
- echo
+ cd e3
+ bash e3_building_config.bash -y -t "${srcdir}/build" -b ${pkgver} setup
}
build() {
cd e3
- #bash e3.bash
+ bash e3.bash base
}
package() {
- echo
+ cd e3
+
#mkdir -p "${pkgdir}/opt/"
#cp -a "${srcdir}/ng3e-${pkgver}/root/${_base_recipe}" "${pkgdir}/opt/epics"
}