summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2014-10-21 02:45:20 +0200
committerJohannes Dewender2014-10-21 02:45:20 +0200
commit2646c134bb2bed62e12c476ce4e660c5ce80b12f (patch)
treee55d5188be7aeb2e5d18a00009862df9f2bd0a18
downloadaur-2646c134bb2bed62e12c476ce4e660c5ce80b12f.tar.gz
essentia-acousticbrainz: created from essentia
This uses a specific commit that is also used for the acousticbrainz-provided binaries. We build that one example the acousticbrainz-client needs and only install that. No conflict with the essentia package.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD39
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f920d84a7f44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = essentia-acousticbrainz
+ pkgdesc = Open-source C++ library for audio analysis and audio-based music information retrieval
+ pkgver = 2.1_beta1.r28.g21ef5f4
+ pkgrel = 1
+ url = http://essentia.upf.edu/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = python2
+ depends = libyaml
+ depends = fftw
+ depends = ffmpeg
+ depends = taglib
+ depends = libsamplerate
+ source = git+https://github.com/MTG/essentia.git#commit=21ef5f41f15ed1f80c8f9b36802430055d3b93e9
+ md5sums = SKIP
+
+pkgname = essentia-acousticbrainz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18ae2688124a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Contributor: Nils Werner <nils DOT werner AT gmail DOT com>
+pkgname='essentia-acousticbrainz'
+_pkgname='essentia'
+_python=python2
+# only change when acousticbrainz provided binaries also change !
+_AB_COMMIT=21ef5f41f15ed1f80c8f9b36802430055d3b93e9
+
+pkgver=2.1_beta1.r28.g21ef5f4
+pkgrel=1
+pkgdesc="Open-source C++ library for audio analysis and audio-based music information retrieval"
+url="http://essentia.upf.edu/"
+arch=('x86_64' 'i686')
+license=('GPL')
+makedepends=('python2')
+depends=('libyaml' 'fftw' 'ffmpeg' 'taglib' 'libsamplerate')
+source=("git+https://github.com/MTG/$_pkgname.git#commit=$_AB_COMMIT")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed -e 's/^v//' -e 's/-/.r/' -e 's/-/\./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ #PYTHON=/usr/bin/python2 python2 waf configure \
+ $_python waf configure \
+ --mode=release --prefix=/usr/ \
+ --with-example=streaming_extractor_music
+ #PYTHON=/usr/bin/python2 python2 waf --prefix=/usr/
+ $_python waf --prefix=/usr/
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D build/src/examples/streaming_extractor_music \
+ $pkgdir/usr/bin/streaming_extractor_music
+}