summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Cherny2017-11-12 15:50:26 +0200
committerEugene Cherny2017-11-12 15:50:26 +0200
commitd5df3a9b8f09f77e29f481c7695ba69a6700d56d (patch)
treefd1e7828232c8b7005769f94e8ef55d5f912348d
downloadaur-d5df3a9b8f09f77e29f481c7695ba69a6700d56d.tar.gz
[init]
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD52
-rw-r--r--pthread_flag.patch15
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04cdcc956a26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = essentia-git
+ pkgdesc = Open-source library and tools for audio and music analysis, description and synthesis. (With Python 3 bindings)
+ pkgver = r1687.52585c53
+ pkgrel = 1
+ url = http://essentia.upf.edu/documentation/
+ arch = x86_64
+ license = AGPL
+ makedepends = git
+ makedepends = python
+ makedepends = glibc
+ depends = fftw
+ depends = ffmpeg
+ depends = libsamplerate
+ depends = taglib
+ depends = libyaml
+ depends = python
+ depends = python-numpy
+ depends = python-yaml
+ provides = essentia
+ conflicts = essentia
+ conflicts = essentia-acousticbrainz
+ conflicts = lib32-essentia-acousticbrainz
+ source = git+https://github.com/MTG/essentia.git#branch=master
+ source = pthread_flag.patch
+ md5sums = SKIP
+ md5sums = 172b1a047ab19d3a11affe47204fc540
+
+pkgname = essentia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28824f5fdade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Eugene Cherny <iam@oscii.ru>
+pkgname=essentia-git
+pkgrel=1
+pkgver=r1687.52585c53
+pkgdesc='Open-source library and tools for audio and music analysis,
+description and synthesis. (With Python 3 bindings)'
+arch=('x86_64')
+url="http://essentia.upf.edu/documentation/"
+license=('AGPL')
+makedepends=('git' 'python' 'glibc')
+depends=('fftw' 'ffmpeg' 'libsamplerate' 'taglib' 'libyaml'
+ 'python' 'python-numpy' 'python-yaml')
+provides=('essentia')
+conflicts=('essentia' 'essentia-acousticbrainz'
+ 'lib32-essentia-acousticbrainz')
+source=('git+https://github.com/MTG/essentia.git#branch=master'
+ 'pthread_flag.patch')
+md5sums=('SKIP'
+ '172b1a047ab19d3a11affe47204fc540')
+
+pkgver() {
+ cd "$srcdir/essentia"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ patch -f "$srcdir/essentia/wscript" pthread_flag.patch
+}
+
+build() {
+ cd "$srcdir/essentia"
+ ./waf configure \
+ --mode=release \
+ --build-static \
+ --with-cpptests \
+ --with-examples \
+ --with-python \
+ --python=$(which python) \
+ --prefix="$pkgdir/usr"
+ ./waf
+}
+
+#check() {
+# cd "$srcdir/$pkgname"
+# ./waf run_tests
+# ./waf run_python_tests
+#}
+
+package() {
+ cd "$srcdir/essentia"
+ ./waf install
+}
diff --git a/pthread_flag.patch b/pthread_flag.patch
new file mode 100644
index 000000000000..de89ce197b69
--- /dev/null
+++ b/pthread_flag.patch
@@ -0,0 +1,15 @@
+diff --git a/wscript b/wscript
+index fb43390a..c71b4969 100644
+--- a/wscript
++++ b/wscript
+@@ -281,8 +281,8 @@ def build(ctx):
+
+ if ctx.env.WITH_CPPTESTS:
+ # missing -lpthread flag on Ubuntu and LinuxMint
+- if platform.dist()[0].lower() in ['debian', 'ubuntu', 'linuxmint'] and not ctx.env.CROSS_COMPILE_MINGW32 and not ctx.env.WITH_STATIC_EXAMPLES:
+- ext_paths = ['/usr/lib/i386-linux-gnu', '/usr/lib/x86_64-linux-gnu']
++ if not ctx.env.CROSS_COMPILE_MINGW32 and not ctx.env.WITH_STATIC_EXAMPLES:
++ ext_paths = ['/usr/lib32', '/usr/lib']
+ ctx.read_shlib('pthread', paths=ext_paths)
+ ctx.env.USES += ' pthread'
+