summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorObscurely2022-12-11 05:13:53 +0200
committerObscurely2022-12-11 05:13:53 +0200
commit0fdf2ac0a45dd8e66ad9724ac3d28d6d616bbd22 (patch)
treeb49118d308c010f37329304262c25a9f0897406b
parentdaf9f7c37cf8060ffaa345312d8e91621a7d7618 (diff)
downloadaur-0fdf2ac0a45dd8e66ad9724ac3d28d6d616bbd22.tar.gz
fix
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4e3b5bbb213..5cce71981522 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = estash-git
pkgdesc = An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file.
- pkgver = 0.5.1
+ pkgver = v0.5.1.10.g2f8e6bb
pkgrel = 1
url = https://github.com/Obscurely/EStash
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = estash-git
provides = estash-git
conflicts = estash-bin
conflicts = estash
- source = git+https://github.com/Obscurely/EStash
+ source = git+https://github.com/Obscurely/estash
sha256sums = SKIP
pkgname = estash-git
diff --git a/PKGBUILD b/PKGBUILD
index 95da2f4cdc50..591991b4fc36 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
pkgname=estash-git
-pkgver=0.5.1
+pkgver=v0.5.1.10.g2f8e6bb
pkgrel=1
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
@@ -9,12 +9,12 @@ license=('GPL3')
makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
provides=('estash-git')
conflicts=('estash-bin' 'estash')
-source=('git+https://github.com/Obscurely/EStash')
+source=('git+https://github.com/Obscurely/estash')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
@@ -40,5 +40,5 @@ package() {
install -Dm755 target/release/estash -t "${pkgdir}/usr/bin/"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
- install -Dm644 docs/README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
}