summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorObscurely2022-12-10 19:19:46 +0200
committerObscurely2022-12-10 19:19:46 +0200
commitbbc6273b09c7ac67fac281d506527d53aa7d526d (patch)
tree5f0a70afc65c3cf0abc0e3d81461c83af04434d6
downloadaur-bbc6273b09c7ac67fac281d506527d53aa7d526d.tar.gz
initial commit
-rwxr-xr-x.SRCINFO29
-rwxr-xr-xPKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..f4e3b5bbb213
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = estash-git
+ pkgdesc = An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/Obscurely/EStash
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ makedepends = binutils
+ makedepends = libx11
+ makedepends = libxext
+ makedepends = libxft
+ makedepends = libxinerama
+ makedepends = libxcursor
+ makedepends = libxrender
+ makedepends = libxfixes
+ makedepends = pango
+ makedepends = cairo
+ makedepends = libgl
+ makedepends = mesa
+ provides = estash-git
+ conflicts = estash-bin
+ conflicts = estash
+ source = git+https://github.com/Obscurely/EStash
+ sha256sums = SKIP
+
+pkgname = estash-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..60ace9d545f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
+pkgname=estash-git
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
+arch=('x86_64')
+url="https://github.com/Obscurely/EStash"
+license=('GPL3')
+makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
+provides=('estash-git')
+conflicts=('estash-bin' 'estash')
+source=('git+https://github.com/Obscurely/EStash')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+ cd "$srcdir/${pkgname%-git}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+ cd "$srcdir/${pkgname%-git}"
+ cargo build --release --frozen
+ strip target/release/dym
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ install -Dm755 target/release/dym -t "${pkgdir}/usr/bin/"
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
+ install -Dm644 docs/README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+}