summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorObscurely2022-12-11 08:07:02 +0200
committerObscurely2022-12-11 08:07:02 +0200
commitecc930c0c7f47b6daa87c07c847aadbfc2adea35 (patch)
tree3a34d38b833d70432ee098e5d6e07b16f8185e1b
parenta567e4831a4fc5c7d3b078ef2f0bd735db359bee (diff)
downloadaur-ecc930c0c7f47b6daa87c07c847aadbfc2adea35.tar.gz
add desktop file
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78a5cbdbf2dd..18024dc64524 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = estash-git
pkgdesc = An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file.
- pkgver = v0.6.0
- pkgrel = 1
+ pkgver = v0.6.0.4.g12e33e9
+ pkgrel = 2
url = https://github.com/Obscurely/EStash
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index bef26a8e3e30..fcb62c09b582 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
pkgname=estash-git
-pkgver=v0.6.0
-pkgrel=1
+pkgver=v0.6.0.4.g12e33e9
+pkgrel=2
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
url="https://github.com/Obscurely/EStash"
@@ -41,4 +41,9 @@ package() {
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "linux/desktop/EStash.desktop"
+ for size in 16x16 24x24 32x32 48x48 64x64 128x128 256x256; do
+ install -Dm0644 "linux/desktop/icons/hicolor/$size/apps/estash.png" \
+ "$pkgdir/usr/share/icons/hicolor/$size/apps/estash.png"
+ done
}