summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-06-10 13:14:51 +0200
committerSefa Eyeoglu2019-06-10 13:14:51 +0200
commite9abb9f13433a152cfcbddf7f2e4eab3c8f72a86 (patch)
tree1272d53fc1cc14b012801c5e3d66ecfecba9a8d7
parentf9230612e80f4c5fdc434ba476c19046c6d66c00 (diff)
downloadaur-e9abb9f13433a152cfcbddf7f2e4eab3c8f72a86.tar.gz
upgpkg: eta-git r14.d91d294-2
Reformat PKGBUILD
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 552f882f70d7..2bc6d34398ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,25 +8,29 @@ pkgdesc="Tool for monitoring ETA and progress of an arbitrary process"
arch=("any")
url="https://github.com/aioobe/eta"
license=("GPL3")
+
depends=()
makedepends=("git" "gcc")
-source=(
- "${_pkgname}::git+https://github.com/aioobe/eta.git"
-)
+
+source=("${_pkgname}::git+https://github.com/aioobe/eta.git")
sha512sums=("SKIP")
+
pkgver() {
cd "${_pkgname}"
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "${_pkgname}"
+
make
}
package() {
cd "${_pkgname}"
+
install -Dm 755 "eta" "${pkgdir}/usr/bin/eta"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/doc/${_pkgname}/LICENSE"