summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuoyun Wei2016-08-04 15:47:53 +0800
committerZhuoyun Wei2016-08-04 15:47:53 +0800
commit4e75a049e2c2d79e9c4ee356db38f5ba83d10eb1 (patch)
tree0a4b03b8a2bbdf011bc50d7d702630b31af19ce5
downloadaur-4e75a049e2c2d79e9c4ee356db38f5ba83d10eb1.tar.gz
[etcd-bin] 3.0.4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecc35d6baaa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Aug 4 07:47:26 UTC 2016
+pkgbase = etcd-bin
+ pkgdesc = A highly-available key value store for shared configuration and service discovery - binary version
+ pkgver = 3.0.4
+ pkgrel = 1
+ url = https://github.com/coreos/etcd
+ arch = x86_64
+ license = Apache
+ provides = etcd
+ conflicts = etcd
+ conflicts = etcd-git
+ backup = etc/etcd/etcd.conf.yml
+ source = https://github.com/coreos/etcd/releases/download/v3.0.4/etcd-v3.0.4-linux-amd64.tar.gz
+ source = https://github.com/coreos/etcd/raw/v3.0.4/contrib/systemd/etcd.service
+ source = https://github.com/coreos/etcd/raw/v3.0.4/etcd.conf.yml.sample
+ sha256sums = 788f9f74e605cf33be21f2f3a7c96e6691efd5e09a081d18dc222a78d080b917
+ sha256sums = 4975fce5c726f886b71d11edf3ad719c8522e31ac6f735d0d9cfcd4dd713a343
+ sha256sums = 177f2b9c4cf1570719557f9278183cfa40fbe6d6d9879c5cea0c4b73268b3e3b
+
+pkgname = etcd-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29e3672d9928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+
+pkgname=etcd-bin
+_pkgname=etcd
+pkgver=3.0.4
+pkgrel=1
+pkgdesc='A highly-available key value store for shared configuration and service discovery - binary version'
+arch=('x86_64')
+url='https://github.com/coreos/etcd'
+license=('Apache')
+provides=('etcd')
+conflicts=('etcd' 'etcd-git')
+backup=('etc/etcd/etcd.conf.yml')
+source=("https://github.com/coreos/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux-amd64.tar.gz"
+ "https://github.com/coreos/${_pkgname}/raw/v${pkgver}/contrib/systemd/${_pkgname}.service"
+ "https://github.com/coreos/${_pkgname}/raw/v${pkgver}/${_pkgname}.conf.yml.sample")
+sha256sums=('788f9f74e605cf33be21f2f3a7c96e6691efd5e09a081d18dc222a78d080b917'
+ '4975fce5c726f886b71d11edf3ad719c8522e31ac6f735d0d9cfcd4dd713a343'
+ '177f2b9c4cf1570719557f9278183cfa40fbe6d6d9879c5cea0c4b73268b3e3b')
+
+package() {
+ install -Dm644 ${srcdir}/etcd.conf.yml.sample ${pkgdir}/etc/etcd/etcd.conf.yml
+ install -Dm644 ${srcdir}/${_pkgname}.service ${pkgdir}/usr/lib/systemd/system/${_pkgname}.service
+ cd "${srcdir}/${_pkgname}-v${pkgver}-linux-amd64"
+ install -Dm755 etcd ${pkgdir}/usr/bin/etcd
+ install -Dm755 etcdctl ${pkgdir}/usr/bin/etcdctl
+}
+
+# vim:set ts=2 sw=2 et: