summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-07-21 21:03:37 +0100
committerAndrew Stubbs2017-07-21 21:03:37 +0100
commit67d0f5265df2c5b2e7371b4904cc92c29c924778 (patch)
treee567c2750aa5e2cb4e916811f1e64443c7a71d87
parent88276af9dedec8799854f1292f682b5d00d54807 (diff)
downloadaur-67d0f5265df2c5b2e7371b4904cc92c29c924778.tar.gz
Revert "1.1.0"
This reverts commit 88276af9dedec8799854f1292f682b5d00d54807.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 870ef475c7a3..7c2044445e50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jul 21 14:23:49 UTC 2017
+# Fri May 12 08:57:43 UTC 2017
pkgbase = etcher
pkgdesc = Burn images to SD cards & USB drives, safe & easy
- pkgver = 1.1.0
+ pkgver = 1.0.0_1
pkgrel = 1
url = http://www.etcher.io/
arch = i686
@@ -30,13 +30,13 @@ pkgbase = etcher
source = etcher.in
source = Etcher.desktop
source = etcher.png
- sha256sums = 48232d91a275df4f09249aad2b43af3e71e8436bda49c79b591e92e4f3a33922
- sha256sums = a271329e1f3dc952ab43cc3364794e7db0e62990f3e929df3e275e39c28d3980
- sha256sums = 6c47238675cae3c7e580a62cc836a56eb44ace1346607896f1fe16c2185f3c06
- source_i686 = https://github.com/resin-io/etcher/releases/download/v1.1.0/etcher-1.1.0-linux-x86.zip
- sha256sums_i686 = daaed69f0c517bef36588b6c1fc1726e4d393405b9be9b2955fc34808836cfd7
- source_x86_64 = https://github.com/resin-io/etcher/releases/download/v1.1.0/etcher-1.1.0-linux-x64.zip
- sha256sums_x86_64 = cb4cefb0eaa7f555bfc448dcea1b76c806d4e1301c696e8f7ce9e26da2286ee8
+ md5sums = 45deb94dca8036000f4c03a1634929ee
+ md5sums = bba3a3ed1d8ea4d3a9d1ad642dad3225
+ md5sums = 7bd70ef05c6293e36938240be2558091
+ source_i686 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0/Etcher-1.0.0-linux-x86.zip
+ md5sums_i686 = f0c66289590b9ea04b7b672fa7d32fb1
+ source_x86_64 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0/Etcher-1.0.0-linux-x64.zip
+ md5sums_x86_64 = d89bc12f43573bfad76b597f79681b1e
pkgname = etcher
diff --git a/PKGBUILD b/PKGBUILD
index 8572fa00ec81..5e6895e3d316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-realver=1.1.0
-pkgver=${realver//-/_}
+realver=1.0.0
+pkgver=${realver//-/_}_1
pkgrel=1
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
arch=('i686' 'x86_64')
@@ -15,28 +15,28 @@ optdepends=('libnotify: for notifications'
source=("etcher.in"
"Etcher.desktop"
"etcher.png")
-source_i686=("https://github.com/resin-io/etcher/releases/download/v$realver/etcher-$realver-linux-x86.zip")
-source_x86_64=("https://github.com/resin-io/etcher/releases/download/v$realver/etcher-$realver-linux-x64.zip")
+source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x86.zip")
+source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x64.zip")
options=("!strip")
-sha256sums=('48232d91a275df4f09249aad2b43af3e71e8436bda49c79b591e92e4f3a33922'
- 'a271329e1f3dc952ab43cc3364794e7db0e62990f3e929df3e275e39c28d3980'
- '6c47238675cae3c7e580a62cc836a56eb44ace1346607896f1fe16c2185f3c06')
-sha256sums_i686=('daaed69f0c517bef36588b6c1fc1726e4d393405b9be9b2955fc34808836cfd7')
-sha256sums_x86_64=('cb4cefb0eaa7f555bfc448dcea1b76c806d4e1301c696e8f7ce9e26da2286ee8')
-
-
-appimage() {
- a=${pkgarch/i686/i386}
- echo "etcher-$realver-$a.AppImage"
-}
+md5sums=('45deb94dca8036000f4c03a1634929ee'
+ 'bba3a3ed1d8ea4d3a9d1ad642dad3225'
+ '7bd70ef05c6293e36938240be2558091')
+md5sums_i686=('f0c66289590b9ea04b7b672fa7d32fb1')
+md5sums_x86_64=('d89bc12f43573bfad76b597f79681b1e')
build() {
- sed "s/##AppImage##/$(appimage)/g" etcher.in > etcher
+ local a=x86
+ [ "$pkgarch" == "x86_64" ] && a=x64
+
+ sed "s/##AppImage##/Etcher-$realver-linux-$a.AppImage/g" etcher.in > etcher
}
package() {
+ local a=x86
+ [ "$pkgarch" == "x86_64" ] && a=x64
+
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "$(appimage)" "$pkgdir/usr/share/etcher/$(appimage)"
+ install -D "Etcher-$realver-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-$realver-linux-$a.AppImage"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}