summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-07-25 17:58:34 +0100
committerAndrew Stubbs2017-07-25 17:58:34 +0100
commitdf68933e41e02837f2413978f39c073a023924c5 (patch)
tree7776e508320f9177839a674643ac2b8042f348e5
parent67d0f5265df2c5b2e7371b4904cc92c29c924778 (diff)
downloadaur-df68933e41e02837f2413978f39c073a023924c5.tar.gz
v1.1.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 25 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c2044445e50..433c8335f452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri May 12 08:57:43 UTC 2017
+# Tue Jul 25 16:57:36 UTC 2017
pkgbase = etcher
pkgdesc = Burn images to SD cards & USB drives, safe & easy
- pkgver = 1.0.0_1
+ pkgver = 1.1.1
pkgrel = 1
url = http://www.etcher.io/
- arch = i686
arch = x86_64
license = apache
depends = gtk2
@@ -30,13 +29,11 @@ pkgbase = etcher
source = etcher.in
source = Etcher.desktop
source = etcher.png
- md5sums = 45deb94dca8036000f4c03a1634929ee
- md5sums = bba3a3ed1d8ea4d3a9d1ad642dad3225
- md5sums = 7bd70ef05c6293e36938240be2558091
- source_i686 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0/Etcher-1.0.0-linux-x86.zip
- md5sums_i686 = f0c66289590b9ea04b7b672fa7d32fb1
- source_x86_64 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0/Etcher-1.0.0-linux-x64.zip
- md5sums_x86_64 = d89bc12f43573bfad76b597f79681b1e
+ sha256sums = 48232d91a275df4f09249aad2b43af3e71e8436bda49c79b591e92e4f3a33922
+ sha256sums = a271329e1f3dc952ab43cc3364794e7db0e62990f3e929df3e275e39c28d3980
+ sha256sums = 6c47238675cae3c7e580a62cc836a56eb44ace1346607896f1fe16c2185f3c06
+ source_x86_64 = https://github.com/resin-io/etcher/releases/download/v1.1.1/etcher-1.1.1-linux-x64.zip
+ sha256sums_x86_64 = 120782ccc3a4971bb5893738c4ac74a48566cd71212995dd1fd21cc022f85ef8
pkgname = etcher
diff --git a/PKGBUILD b/PKGBUILD
index 5e6895e3d316..4d0dc157cfff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-realver=1.0.0
-pkgver=${realver//-/_}_1
+realver=1.1.1
+pkgver=${realver//-/_}
pkgrel=1
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
-arch=('i686' 'x86_64')
+#arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.etcher.io/"
license=('apache')
depends=('gtk2' 'dbus' 'libxi' 'libxcursor' 'libxdamage' 'libxrandr'
@@ -15,28 +16,27 @@ optdepends=('libnotify: for notifications'
source=("etcher.in"
"Etcher.desktop"
"etcher.png")
-source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x86.zip")
-source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x64.zip")
+source_i686=("https://github.com/resin-io/etcher/releases/download/v$realver/etcher-$realver-linux-x86.zip")
+source_x86_64=("https://github.com/resin-io/etcher/releases/download/v$realver/etcher-$realver-linux-x64.zip")
options=("!strip")
-md5sums=('45deb94dca8036000f4c03a1634929ee'
- 'bba3a3ed1d8ea4d3a9d1ad642dad3225'
- '7bd70ef05c6293e36938240be2558091')
-md5sums_i686=('f0c66289590b9ea04b7b672fa7d32fb1')
-md5sums_x86_64=('d89bc12f43573bfad76b597f79681b1e')
+sha256sums=('48232d91a275df4f09249aad2b43af3e71e8436bda49c79b591e92e4f3a33922'
+ 'a271329e1f3dc952ab43cc3364794e7db0e62990f3e929df3e275e39c28d3980'
+ '6c47238675cae3c7e580a62cc836a56eb44ace1346607896f1fe16c2185f3c06')
+sha256sums_x86_64=('120782ccc3a4971bb5893738c4ac74a48566cd71212995dd1fd21cc022f85ef8')
-build() {
- local a=x86
- [ "$pkgarch" == "x86_64" ] && a=x64
- sed "s/##AppImage##/Etcher-$realver-linux-$a.AppImage/g" etcher.in > etcher
+appimage() {
+ a=${pkgarch/i686/i386}
+ echo "etcher-$realver-$a.AppImage"
}
-package() {
- local a=x86
- [ "$pkgarch" == "x86_64" ] && a=x64
+build() {
+ sed "s/##AppImage##/$(appimage)/g" etcher.in > etcher
+}
+package() {
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "Etcher-$realver-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-$realver-linux-$a.AppImage"
+ install -D "$(appimage)" "$pkgdir/usr/share/etcher/$(appimage)"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}