summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2020-02-21 19:25:33 +0330
committerAli Molaei2020-02-21 19:25:33 +0330
commit872b3fcc9e56fda2a07ef35c8c04dd7542c6309a (patch)
tree1d64fe77c93b2d6d952cadded67bcb5f40f3347f
parent04d9da4a2e12aa868d3a57ca5384dab533949eae (diff)
downloadaur-872b3fcc9e56fda2a07ef35c8c04dd7542c6309a.tar.gz
Update to 1.5.79, Update dependencies checked by ldd
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD44
2 files changed, 78 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 601d05b5a93a..91a2156eabb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,56 @@
pkgbase = etcher-bin
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.5.76
+ pkgver = 1.5.79
pkgrel = 1
url = http://www.etcher.io/
arch = x86_64
license = apache
makedepends = bzip2
depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = avahi
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = fribidi
+ depends = gdk-pixbuf2
+ depends = graphite
+ depends = gtk3
+ depends = harfbuzz
+ depends = libcups
+ depends = libdatrie
+ depends = libepoxy
+ depends = libpng
+ depends = libthai
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxdmcp
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxrender
depends = libxss
depends = libxtst
- depends = nss
+ depends = pango
+ depends = pixman
+ depends = wayland
optdepends = libnotify: for notifications
optdepends = speech-dispatcher: for text-to-speech
provides = etcher
conflicts = etcher
options = !strip
- source = https://github.com/balena-io/etcher/releases/download/v1.5.76/balena-etcher-electron_1.5.76_amd64.deb
+ source = https://github.com/balena-io/etcher/releases/download/v1.5.79/balena-etcher-electron_1.5.79_amd64.deb
source = etcher
- sha256sums = d9f295fdf31adff849c0327620858d3f06707216db78954677c424351f201692
+ sha256sums = 54af66e849424e898ca60974a01cdce54af61a8a51e75a884700e62ef0824656
sha256sums = ce48173bc432b90543a21c48d6c0f66d8b26d293e02a588f2307992f1861f9d3
pkgname = etcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0730d4e4af59..79c0e22c1d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Andrew Stubbs <andrew dot stubbs at gmail dot com>
pkgname=etcher-bin
-pkgver=1.5.76
+pkgver=1.5.79
pkgrel=1
pkgdesc="Flash OS images to SD cards & USB drives, safely and easily"
arch=("x86_64")
@@ -11,7 +11,45 @@ url="http://www.${pkgname%-bin}.io/"
license=("apache")
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-depends=("alsa-lib" "libxss" "libxtst" "nss")
+depends=(
+ 'alsa-lib'
+ 'atk'
+ 'at-spi2-atk'
+ 'at-spi2-core'
+ 'avahi'
+ 'cairo'
+ 'fontconfig'
+ 'freetype2'
+ 'fribidi'
+ 'gdk-pixbuf2'
+ 'graphite'
+ 'gtk3'
+ 'harfbuzz'
+ 'libcups'
+ 'libdatrie'
+ 'libepoxy'
+ 'libpng'
+ 'libthai'
+ 'libx11'
+ 'libxau'
+ 'libxcb'
+ 'libxcomposite'
+ 'libxcursor'
+ 'libxdamage'
+ 'libxdmcp'
+ 'libxext'
+ 'libxfixes'
+ 'libxi'
+ 'libxinerama'
+ 'libxkbcommon'
+ 'libxrandr'
+ 'libxrender'
+ 'libxss'
+ 'libxtst'
+ 'pango'
+ 'pixman'
+ 'wayland'
+)
makedepends=('bzip2')
optdepends=("libnotify: for notifications"
"speech-dispatcher: for text-to-speech")
@@ -19,7 +57,7 @@ source=("https://github.com/balena-io/${pkgname%-bin}/releases/download/v${pkgve
"etcher")
options=("!strip")
-sha256sums=("d9f295fdf31adff849c0327620858d3f06707216db78954677c424351f201692"
+sha256sums=("54af66e849424e898ca60974a01cdce54af61a8a51e75a884700e62ef0824656"
"ce48173bc432b90543a21c48d6c0f66d8b26d293e02a588f2307992f1861f9d3")
build() {