summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2022-02-28 03:23:18 -0600
committerBao Trinh2022-02-28 03:23:18 -0600
commitdc4eda33599a7441253ffe917f2dc4e23c0c7a76 (patch)
treed9be8489d701795bcb2cf60680cfa057600de3da
parentb7e909556b4666b411e0e70b8d64d5b7a3367303 (diff)
downloadaur-dc4eda33599a7441253ffe917f2dc4e23c0c7a76.tar.gz
fixes
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa1c9f3b8c47..a07e864adad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = etcher-cli-bin
pkgdesc = Burn images to SD cards & USB drives, safe & easy
pkgver = 1.4.9
- pkgrel = 2
+ pkgrel = 3
url = http://www.etcher.io/
+ arch = i686
arch = x86_64
license = Apache
depends = gcc-libs
provides = etcher-cli
conflicts = etcher-cli
conflicts = etcher-cli-git
+ noextract = etcher-cli-bin-1.4.9-x86_64.tar.gz
options = !strip
- source = https://github.com/balena-io/etcher/releases/download/v1.4.9/balena-etcher-cli-1.4.9-linux-x64.tar.gz
- sha256sums = 67d1173fdf7c4c528f4027147463597cffdef9d50ddcf0c74c9651685b1c451e
+ source_i686 = etcher-cli-bin-1.4.9-x86_64.tar.gz::https://github.com/balena-io/etcher/releases/download/v1.4.9/balena-etcher-cli-1.4.9-linux-x86.tar.gz
+ sha256sums_i686 = 4af2f1662fbbc2e7ee9b4d50f52b403b9ca5a1c6a83f56cbf1b6bb5368b90ced
+ source_x86_64 = etcher-cli-bin-1.4.9-x86_64.tar.gz::https://github.com/balena-io/etcher/releases/download/v1.4.9/balena-etcher-cli-1.4.9-linux-x64.tar.gz
+ sha256sums_x86_64 = 4af2f1662fbbc2e7ee9b4d50f52b403b9ca5a1c6a83f56cbf1b6bb5368b90ced
pkgname = etcher-cli-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 9f3b0d2be578..570638c08280 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
+# Maintainer: Bao Trinh <qubidt@gmail.com>
# Contributor: Matthew McGinn <mamcgi@gmail.com>
# Contributor: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher-cli-bin
_pkgname=etcher-cli
pkgver=1.4.9
-pkgrel=2
+pkgrel=3
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="http://www.etcher.io/"
-_github_url="none"
license=('Apache')
provides=('etcher-cli')
conflicts=('etcher-cli' 'etcher-cli-git')
depends=('gcc-libs')
optdepends=()
-source=("https://github.com/balena-io/etcher/releases/download/v${pkgver}/balena-etcher-cli-${pkgver}-linux-x64.tar.gz")
+source_i686=("${pkgname}-${pkgver}-${CARCH}.tar.gz::https://github.com/balena-io/etcher/releases/download/v${pkgver}/balena-etcher-cli-${pkgver}-linux-x86.tar.gz")
+source_x86_64=("${pkgname}-${pkgver}-${CARCH}.tar.gz::https://github.com/balena-io/etcher/releases/download/v${pkgver}/balena-etcher-cli-${pkgver}-linux-x64.tar.gz")
+noextract=("${pkgname}-${pkgver}-${CARCH}.tar.gz")
options=("!strip")
-sha256sums=('67d1173fdf7c4c528f4027147463597cffdef9d50ddcf0c74c9651685b1c451e')
+sha256sums_i686=('4af2f1662fbbc2e7ee9b4d50f52b403b9ca5a1c6a83f56cbf1b6bb5368b90ced')
+sha256sums_x86_64=('4af2f1662fbbc2e7ee9b4d50f52b403b9ca5a1c6a83f56cbf1b6bb5368b90ced')
+
+prepare() {
+ mkdir -p "${pkgname}-${pkgver}-${CARCH}"
+ bsdtar --strip-components 1 -zxf "${pkgname}-${pkgver}.tar.gz" -C "${pkgname}-${pkgver}-${CARCH}"
+}
package() {
- mkdir -p "${pkgdir}/opt"
- mv "${srcdir}/balena-${_pkgname}-${pkgver}-linux-x64-dist" "${pkgdir}/opt/${_pkgname}"
- mkdir -p "${pkgdir}/usr/bin"
- cd "${pkgdir}/usr/bin"
- ln -snf "../../opt/${_pkgname}/balena-etcher" "etcher-cli"
+ install -dm755 "${pkgdir}/opt"
+ cp -ra "${pkgname}-${pkgver}-${CARCH}" "${pkgdir}/opt/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -snf "/opt/${_pkgname}/balena-etcher" "${pkgdir}/usr/bin/etcher-cli"
}