summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-11 22:34:12 +0100
committerNarrat2020-01-11 22:34:12 +0100
commit9b1ae1cf1a2001cea5448bc3fd89dc3af55720da (patch)
tree1bb46d990d0c43c0d8b6644d3245c1cdcb867655
parente5bc8a6cb3acdb10282ad577c0da347f57974f62 (diff)
downloadaur-etcher-cli-git.tar.gz
Small changes
resin-io got renamed/changed to balena-io. Added submodule handling. And small adjustment to the pkgver
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61f95ae2befb..9d22686b6436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = etcher-cli-git
pkgdesc = Burn images to SD cards & USB drives, safe & easy
- pkgver = v1.4.1.0.g1c43ee1b
+ pkgver = 1.5.70.r0.g57145436
pkgrel = 1
url = http://www.etcher.io/
arch = x86_64
- license = apache
+ license = Apache
makedepends = npm
provides = etcher-cli
conflicts = etcher-cli
- source = etcher-cli-git::git+https://github.com/resin-io/etcher.git
+ source = etcher-cli-git::git+https://github.com/balena-io/etcher.git
sha256sums = SKIP
pkgname = etcher-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 90e937f79750..f0c3a9663ab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
-# Maintainer: Håvard Pettersson <mail@haavard.me>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Håvard Pettersson <mail@haavard.me>
# Contributor: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher-cli-git
-pkgver=v1.4.1.0.g1c43ee1b
+pkgver=1.5.70.r0.g57145436
pkgrel=1
pkgdesc='Burn images to SD cards & USB drives, safe & easy'
arch=(x86_64)
url='http://www.etcher.io/'
-license=(apache)
+license=(Apache)
makedepends=(npm)
conflicts=(etcher-cli)
provides=(etcher-cli)
-source=("$pkgname::git+https://github.com/resin-io/etcher.git")
+source=("$pkgname::git+https://github.com/balena-io/etcher.git")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --tags --long | sed 's/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+}
+
+prepare() {
+ cd $pkgname
+ git submodule init
+ git submodule update
}
build() {