summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2021-04-14 10:45:07 +0200
committerAngelo Theodorou2021-04-14 10:46:59 +0200
commit0df1d1e8c3d764fed68a85425b82f0014070fdaa (patch)
tree57dd03f1a93ce46a46d9bdc4efa34f036b39b7a7
parent91482057ee6fe7c8d241f37d7c47e0d87b1ffb16 (diff)
downloadaur-0df1d1e8c3d764fed68a85425b82f0014070fdaa.tar.gz
Update client and data to 1.9.5.9
- Use GitHub release archive for sources - Add sdl2_ttf to the depends array - Remove git from the makedepends array - Update the list of installed data files
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--eternallands.changelog9
3 files changed, 28 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ac97c4b045b..c70178cbcd0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = eternallands
pkgdesc = A free 3D MMORPG game with thousands of on-line players
- pkgver = 1.9.5.8
- pkgrel = 3
+ pkgver = 1.9.5.9
+ pkgrel = 1
url = http://www.eternal-lands.com/
changelog = eternallands.changelog
arch = i686
arch = x86_64
license = custom
- makedepends = git
makedepends = unzip
makedepends = pkgconf
depends = sdl2_net
depends = sdl2_image
+ depends = sdl2_ttf
depends = openal
depends = cal3d
depends = libvorbis
@@ -19,10 +19,10 @@ pkgbase = eternallands
optdepends = zenity: to use the launch script
optdepends = kdialog: to use the launch script
options = !emptydirs
- source = git://github.com/raduprv/Eternal-Lands.git#tag=1.9.5.8
- source = https://github.com/raduprv/Eternal-Lands/releases/download/1.9.5.7/el_195_p7_data_files.zip
- md5sums = SKIP
- md5sums = c58b6f374d0f9ce3f0aa0fe4eab348d5
+ source = https://github.com/raduprv/Eternal-Lands/archive/refs/tags/1.9.5.9-1.tar.gz
+ source = https://github.com/raduprv/Eternal-Lands/releases/download/1.9.5.9-1/eternallands-data_1.9.5.9-1.zip
+ md5sums = 745a75f442d6afea31df5d388450082a
+ md5sums = 82c0b5601faed923fb30d01906e25ca3
pkgname = eternallands
diff --git a/PKGBUILD b/PKGBUILD
index d01f971320f8..6adccc02d853 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,24 @@
# Maintainer: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=eternallands
-pkgver=1.9.5.8
-pkgrel=3
+pkgver=1.9.5.9
+version=${pkgver}-1
+pkgrel=1
pkgdesc="A free 3D MMORPG game with thousands of on-line players"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.eternal-lands.com/"
-depends=('sdl2_net' 'sdl2_image' 'openal' 'cal3d' 'libvorbis' 'glu')
-makedepends=('git' 'unzip' 'pkgconf')
+depends=('sdl2_net' 'sdl2_image' 'sdl2_ttf' 'openal' 'cal3d' 'libvorbis' 'glu')
+makedepends=('unzip' 'pkgconf')
optdepends=('zenity: to use the launch script' 'kdialog: to use the launch script')
options=('!emptydirs')
changelog=eternallands.changelog
-source=("git://github.com/raduprv/Eternal-Lands.git#tag=${pkgver}" 'https://github.com/raduprv/Eternal-Lands/releases/download/1.9.5.7/el_195_p7_data_files.zip')
-md5sums=('SKIP' 'c58b6f374d0f9ce3f0aa0fe4eab348d5')
+source=("https://github.com/raduprv/Eternal-Lands/archive/refs/tags/${version}.tar.gz" "https://github.com/raduprv/Eternal-Lands/releases/download/${version}/eternallands-data_${version}.zip")
+md5sums=('745a75f442d6afea31df5d388450082a' '82c0b5601faed923fb30d01906e25ca3')
build()
{
- cd ${srcdir}/Eternal-Lands
+ cd ${srcdir}/Eternal-Lands-${version}
sed -i "s|/usr/games/|/usr/bin/|" pkgfiles/eternallands
sed -i "s|/usr/share/games/EternalLands/|/usr/share/eternallands/|" pkgfiles/eternallands
@@ -32,7 +33,7 @@ build()
}
package() {
- cd ${srcdir}/Eternal-Lands
+ cd ${srcdir}/Eternal-Lands-${version}
mkdir -p "${pkgdir}/usr/bin"
mkdir -p "${pkgdir}/usr/share/man/man6"
@@ -44,7 +45,7 @@ package() {
install -m755 el.x86.linux.bin "${pkgdir}/usr/bin/"
install -m755 pkgfiles/eternallands "${pkgdir}/usr/bin/"
install -m644 pkgfiles/eternallands.6 "${pkgdir}/usr/share/man/man6"
- install -m644 pkgfiles/el.x86.linux.bin.6 "${pkgdir}/usr/share/man/man6"
+ install -m644 pkgfiles/el.linux.bin.6 "${pkgdir}/usr/share/man/man6"
install -m644 pkgfiles/eternallands.png "${pkgdir}/usr/share/pixmaps/"
install -m644 pkgfiles/eternallands.xpm "${pkgdir}/usr/share/pixmaps/"
install -m644 pkgfiles/eternallands.desktop "${pkgdir}/usr/share/applications"
@@ -55,16 +56,13 @@ package() {
# Compress textures and maps
find \( -name *.bmp -or -name *.elm \) -exec gzip -f {} \;
- for dir in 2dobjects 3dobjects actor_defs animations languages maps meshes particles shaders skeletons skybox textures; do
+ for dir in 2dobjects 3dobjects actor_defs animations fonts languages maps meshes particles shaders skeletons skybox textures; do
cp -R ${dir} "${pkgdir}/usr/share/eternallands/"
done
sed -i "s|^#data_dir = \"c:\\\Program Files\\\Eternal Lands\\\\\"|#data_dir = /usr/share/eternallands|" el.ini
- sed -i "s|^#use_new_selection.*$|#use_new_selection = 1|g" el.ini
- for file in *.ini *.txt *.lst *.xml; do
+ for file in *.ini *.json *.lst *.menu *.txt *.xml; do
install -m644 ${file} "${pkgdir}/usr/share/eternallands/"
done
-
- install -m644 ${srcdir}/Eternal-Lands/el.ini "${pkgdir}/usr/share/eternallands/"
}
diff --git a/eternallands.changelog b/eternallands.changelog
index 189e60fad90a..95c431865671 100644
--- a/eternallands.changelog
+++ b/eternallands.changelog
@@ -1,3 +1,12 @@
+2021-04-14 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD:
+ Updated to client and data 1.9.5.9-1
+ Using GitHub release archive for sources
+ Added sdl2_ttf to the depends array
+ Removed git from the makedepends array
+ Updated the list of installed data files
+
2020-09-19 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD: