summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-02-08 23:56:48 +0100
committer5chdn2016-02-08 23:56:48 +0100
commit0ceebbbe86bb0d00092a507b70a07cf9c089e490 (patch)
treeb9f13aed0a03722779b6d15a33c91f928650aac9
parentcf5b6a083a2a9db7439b8a7c931dfc76f20c28c9 (diff)
downloadaur-0ceebbbe86bb0d00092a507b70a07cf9c089e490.tar.gz
Update v1.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD164
-rw-r--r--libethereum-hotfix-boost-1.60.patch67
-rw-r--r--solidity-hotfix-boost-1.59.patch30
4 files changed, 81 insertions, 188 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c0ff5ff921f..fb2eceabd36f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 14 14:39:20 UTC 2016
+# Mon Feb 8 22:55:56 UTC 2016
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
- pkgver = 1.0.1
+ pkgver = 1.1.2
pkgrel = 1
url = https://github.com/ethereum/webthree-umbrella
arch = i686
@@ -77,11 +77,7 @@ pkgbase = ethereum
conflicts = solc
conflicts = ethereum-git
source = ethereum::git+https://github.com/ethereum/webthree-umbrella
- source = libethereum-hotfix-boost-1.60.patch
- source = solidity-hotfix-boost-1.59.patch
sha256sums = SKIP
- sha256sums = fa1edc2b886337b0907122bd4ed4883bf28cc7571e5e5d3dfc0bb6b7637d3848
- sha256sums = 3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index 8e19b1a7c568..8f286fc003fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,105 +2,99 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethereum
-pkgver=1.0.1
+pkgver=1.1.2
pkgrel=1
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
-depends=('argtable'
- 'boost'
- 'boost-libs'
- 'curl'
- 'crypto++'
- 'gmp'
- 'jsoncpp'
- 'leveldb'
- 'libedit'
- 'libjson-rpc-cpp-git'
- 'libmicrohttpd'
- 'miniupnpc'
- 'ncurses'
- 'ocl-icd'
- 'opencl-headers'
- 'openssl'
- 'python2'
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quick1'
- 'qt5-quickcontrols'
- 'qt5-webengine'
- 'qt5-webkit'
- 'qt5-graphicaleffects'
- 'readline'
- 'snappy'
- 'llvm'
- 'scons'
- 'gperftools')
-makedepends=('autoconf'
- 'automake'
- 'cmake'
- 'gcc'
- 'libtool'
- 'v8-3.15'
- 'yasm'
- 'git'
- 'clang')
+depends=(
+ 'argtable'
+ 'boost'
+ 'boost-libs'
+ 'curl'
+ 'crypto++'
+ 'gmp'
+ 'jsoncpp'
+ 'leveldb'
+ 'libedit'
+ 'libjson-rpc-cpp-git'
+ 'libmicrohttpd'
+ 'miniupnpc'
+ 'ncurses'
+ 'ocl-icd'
+ 'opencl-headers'
+ 'openssl'
+ 'python2'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quick1'
+ 'qt5-quickcontrols'
+ 'qt5-webengine'
+ 'qt5-webkit'
+ 'qt5-graphicaleffects'
+ 'readline'
+ 'snappy'
+ 'llvm'
+ 'scons'
+ 'gperftools'
+)
+makedepends=(
+ 'autoconf'
+ 'automake'
+ 'cmake'
+ 'gcc'
+ 'libtool'
+ 'v8-3.15'
+ 'yasm'
+ 'git'
+ 'clang'
+)
groups=('ethereum')
url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
-source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
- "libethereum-hotfix-boost-1.60.patch"
- "solidity-hotfix-boost-1.59.patch")
-sha256sums=('SKIP'
- 'fa1edc2b886337b0907122bd4ed4883bf28cc7571e5e5d3dfc0bb6b7637d3848'
- '3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2')
-provides=('alethfive'
- 'alethone'
- 'alethzero'
- 'eth'
- 'ethkey'
- 'ethminer'
- 'ethrpctest'
- 'ethvm'
- 'exp'
- 'lllc'
- 'mix'
- 'rlp'
- 'solc'
- 'ethereum'
- 'webthree-umbrella')
-conflicts=('alethfive'
- 'alethone'
- 'alethzero'
- 'eth'
- 'ethkey'
- 'ethminer'
- 'ethrpctest'
- 'ethvm'
- 'exp'
- 'lllc'
- 'mix'
- 'rlp'
- 'solc'
- 'ethereum-git')
+source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella")
+sha256sums=('SKIP')
+provides=(
+ 'alethfive'
+ 'alethone'
+ 'alethzero'
+ 'eth'
+ 'ethkey'
+ 'ethminer'
+ 'ethrpctest'
+ 'ethvm'
+ 'exp'
+ 'lllc'
+ 'mix'
+ 'rlp'
+ 'solc'
+ 'ethereum'
+ 'webthree-umbrella'
+)
+conflicts=(
+ 'alethfive'
+ 'alethone'
+ 'alethzero'
+ 'eth'
+ 'ethkey'
+ 'ethminer'
+ 'ethrpctest'
+ 'ethvm'
+ 'exp'
+ 'lllc'
+ 'mix'
+ 'rlp'
+ 'solc'
+ 'ethereum-git'
+)
build() {
msg 'Updating...'
cd ${pkgname%-git}
git checkout release
- git checkout $pkgver
+ git checkout v$pkgver
git submodule update --init --recursive
- # Fix libethereum compatibility with boost 1.59, 1.60
- pushd libethereum
- git apply ${srcdir}/libethereum-hotfix-boost-1.60.patch
- popd
-
- # Fix solidity compatibility with boost 1.59
- pushd solidity
- git apply ${srcdir}/solidity-hotfix-boost-1.59.patch
- popd
-
msg 'Building...'
mkdir -p build && pushd build
CXXFLAGS=-Wno-deprecated-declarations cmake .. \
diff --git a/libethereum-hotfix-boost-1.60.patch b/libethereum-hotfix-boost-1.60.patch
deleted file mode 100644
index 4cbaae6841fe..000000000000
--- a/libethereum-hotfix-boost-1.60.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/libethcore/Ethash.cpp b/libethcore/Ethash.cpp
-index 0427514..0b3cfbc 100644
---- a/libethcore/Ethash.cpp
-+++ b/libethcore/Ethash.cpp
-@@ -110,7 +110,12 @@ void Ethash::BlockHeaderRaw::verifyParent(BlockHeaderRaw const& _parent)
- if (m_gasLimit < c_minGasLimit ||
- m_gasLimit <= _parent.m_gasLimit - _parent.m_gasLimit / c_gasLimitBoundDivisor ||
- m_gasLimit >= _parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor)
-- BOOST_THROW_EXCEPTION(InvalidGasLimit() << errinfo_min((bigint)_parent.m_gasLimit - _parent.m_gasLimit / c_gasLimitBoundDivisor) << errinfo_got((bigint)m_gasLimit) << errinfo_max((bigint)_parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor));
-+ BOOST_THROW_EXCEPTION(
-+ InvalidGasLimit()
-+ << errinfo_min((bigint)((bigint)_parent.m_gasLimit - (bigint)(_parent.m_gasLimit / c_gasLimitBoundDivisor)))
-+ << errinfo_got((bigint)m_gasLimit)
-+ << errinfo_max((bigint)((bigint)_parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor))
-+ );
- }
-
- void Ethash::BlockHeaderRaw::populateFromParent(BlockHeaderRaw const& _parent)
-diff --git a/test/boostTest.cpp b/test/boostTest.cpp
-index 7c2b068..2e8dbd9 100644
---- a/test/boostTest.cpp
-+++ b/test/boostTest.cpp
-@@ -57,7 +57,7 @@ test_suite* init_func(int argc, char* argv[])
- //disable post output so the test json would be clean
- std::cout.rdbuf(strCout.rdbuf());
- std::cerr.rdbuf(strCout.rdbuf());
-- throw framework::nothing_to_test();
-+ exit(0);
- }
- }
- return 0;
-@@ -78,10 +78,19 @@ int main( int argc, char* argv[] )
- {
- framework::init(init_func, argc, argv);
-
-+#if BOOST_VERSION >= 106000
-+ if (true)
-+ {
-+ test_case_counter filter;
-+#elif BOOST_VERSION >= 105900
-+ if(!runtime_config::test_to_run().empty())
-+ {
-+ test_case_counter filter;
-+#else
- if( !runtime_config::test_to_run().is_empty() )
- {
- test_case_filter filter(runtime_config::test_to_run());
--
-+#endif
- traverse_test_tree(framework::master_test_suite().p_id, filter);
- }
-
-@@ -89,9 +98,14 @@ int main( int argc, char* argv[] )
-
- results_reporter::make_report();
-
-+#if BOOST_VERSION >= 106000
-+ return results_collector.results(framework::master_test_suite().p_id).result_code();
-+#else
- return runtime_config::no_result_code()
- ? boost::exit_success
- : results_collector.results(framework::master_test_suite().p_id).result_code();
-+#endif
-+
- }
- catch (framework::nothing_to_test const&)
- {
diff --git a/solidity-hotfix-boost-1.59.patch b/solidity-hotfix-boost-1.59.patch
deleted file mode 100644
index 880a61e20d80..000000000000
--- a/solidity-hotfix-boost-1.59.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/test/TestHelper.h b/test/TestHelper.h
-index 0bf6222..94b5ee2 100644
---- a/test/TestHelper.h
-+++ b/test/TestHelper.h
-@@ -46,12 +46,6 @@ namespace test
- { \
- auto msg = std::string(_message " due to an exception thrown by " \
- BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
-- BOOST_CHECK_IMPL(false, msg, REQUIRE, CHECK_MSG); \
-- } \
-- catch (...) \
-- { \
-- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
-- BOOST_STRINGIZE(_statement), REQUIRE, CHECK_MSG); \
- } \
- } \
- while (0)
-@@ -72,12 +66,6 @@ namespace test
- { \
- auto msg = std::string(_message " due to an exception thrown by " \
- BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
-- BOOST_CHECK_IMPL(false, msg, CHECK, CHECK_MSG); \
-- } \
-- catch (...) \
-- { \
-- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
-- BOOST_STRINGIZE(_statement), CHECK, CHECK_MSG ); \
- } \
- } \
- while (0)