summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-04-04 20:07:48 +0200
committer5chdn2016-04-04 20:07:48 +0200
commit172cd9418fb2265dedb406b62fe3694102bd0422 (patch)
tree575b5a29a2f101cc8b0235c4cc90056adf6ca030
parent1aa3c7250fb53ebf5c69e3292ba53c78e0fdda7f (diff)
downloadaur-172cd9418fb2265dedb406b62fe3694102bd0422.tar.gz
Bump version to 1.2.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b287d5e73a5b..08b02f883f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 29 18:30:44 UTC 2016
+# Mon Apr 4 18:07:16 UTC 2016
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
- pkgver = 1.2.2
- pkgrel = 2
+ pkgver = 1.2.3
+ pkgrel = 1
url = https://github.com/ethereum/webthree-umbrella
arch = i686
arch = x86_64
@@ -14,7 +14,6 @@ pkgbase = ethereum
makedepends = cmake
makedepends = gcc
makedepends = libtool
- makedepends = v8-3.15
makedepends = yasm
makedepends = git
makedepends = clang
@@ -46,6 +45,7 @@ pkgbase = ethereum
depends = snappy
depends = llvm
depends = scons
+ depends = v8-3.15
depends = gperftools
provides = alethone
provides = alethzero
@@ -74,9 +74,7 @@ pkgbase = ethereum
conflicts = solc
conflicts = ethereum-git
source = ethereum::git+https://github.com/ethereum/webthree-umbrella
- source = qt56.patch::https://github.com/ethereum/alethzero/commit/543a1669e32c9c4403893a46a596eeaedaf28518.patch
sha256sums = SKIP
- sha256sums = 6ad2ac07b1c2fa734dcd397baa10e5b4adc81e00354e13fbbdd70c66036a8556
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index e508efbe8db8..9a6b24fde994 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethereum
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.2.3
+pkgrel=1
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
depends=(
@@ -35,6 +35,7 @@ depends=(
'snappy'
'llvm'
'scons'
+ 'v8-3.15'
'gperftools'
)
makedepends=(
@@ -43,7 +44,6 @@ makedepends=(
'cmake'
'gcc'
'libtool'
- 'v8-3.15'
'yasm'
'git'
'clang'
@@ -53,11 +53,9 @@ url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
source=(
"${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
- 'qt56.patch::https://github.com/ethereum/alethzero/commit/543a1669e32c9c4403893a46a596eeaedaf28518.patch'
)
sha256sums=(
'SKIP'
- '6ad2ac07b1c2fa734dcd397baa10e5b4adc81e00354e13fbbdd70c66036a8556'
)
provides=(
'alethone'
@@ -99,11 +97,6 @@ build() {
git checkout v$pkgver
git submodule update --init --recursive
- msg 'Patching...'
- cd alethzero
- git apply ${srcdir}/qt56.patch
- cd ..
-
msg 'Building...'
mkdir -p build && pushd build
cmake .. \
@@ -119,6 +112,8 @@ package() {
msg 'Installing...'
make DESTDIR="$pkgdir" install -C build
+ mv $pkgdir/usr/bin/mix $pkgdir/usr/bin/mix-ide
+
msg 'Cleaning up pkgdir...'
find "$pkgdir" -type d -name .git -exec rm -r '{}' +
find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +