summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvertoe2016-03-29 20:31:12 +0200
committervertoe2016-03-29 20:31:12 +0200
commit1aa3c7250fb53ebf5c69e3292ba53c78e0fdda7f (patch)
tree7e38accfa5edbd55217d9206845bd4f80d6bd21d
parent65088aad705e480adb7eea21a589c8f8bc2959ba (diff)
downloadaur-1aa3c7250fb53ebf5c69e3292ba53c78e0fdda7f.tar.gz
Qt 5.6 hotfix.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6d4f12004c0..b287d5e73a5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 11 20:50:00 UTC 2016
+# Tue Mar 29 18:30:44 UTC 2016
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
pkgver = 1.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ethereum/webthree-umbrella
arch = i686
arch = x86_64
@@ -47,7 +47,6 @@ pkgbase = ethereum
depends = llvm
depends = scons
depends = gperftools
- provides = alethfive
provides = alethone
provides = alethzero
provides = eth
@@ -61,8 +60,6 @@ pkgbase = ethereum
provides = rlp
provides = solc
provides = ethereum
- provides = webthree-umbrella
- conflicts = alethfive
conflicts = alethone
conflicts = alethzero
conflicts = eth
@@ -77,7 +74,9 @@ pkgbase = ethereum
conflicts = solc
conflicts = ethereum-git
source = ethereum::git+https://github.com/ethereum/webthree-umbrella
+ source = qt56.patch::https://github.com/ethereum/alethzero/commit/543a1669e32c9c4403893a46a596eeaedaf28518.patch
sha256sums = SKIP
+ sha256sums = 6ad2ac07b1c2fa734dcd397baa10e5b4adc81e00354e13fbbdd70c66036a8556
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index 7421d24e5735..e508efbe8db8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ethereum
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
depends=(
@@ -51,10 +51,15 @@ makedepends=(
groups=('ethereum')
url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
-source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella")
-sha256sums=('SKIP')
+source=(
+ "${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
+ 'qt56.patch::https://github.com/ethereum/alethzero/commit/543a1669e32c9c4403893a46a596eeaedaf28518.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '6ad2ac07b1c2fa734dcd397baa10e5b4adc81e00354e13fbbdd70c66036a8556'
+)
provides=(
- 'alethfive'
'alethone'
'alethzero'
'eth'
@@ -68,10 +73,8 @@ provides=(
'rlp'
'solc'
'ethereum'
- 'webthree-umbrella'
)
conflicts=(
- 'alethfive'
'alethone'
'alethzero'
'eth'
@@ -92,14 +95,20 @@ build() {
msg 'Updating...'
cd ${pkgname%-git}
git checkout release
+ git pull
git checkout v$pkgver
git submodule update --init --recursive
+ msg 'Patching...'
+ cd alethzero
+ git apply ${srcdir}/qt56.patch
+ cd ..
+
msg 'Building...'
mkdir -p build && pushd build
- CXXFLAGS=-Wno-deprecated-declarations cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
make
popd
}