summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvertoe2015-10-19 22:52:23 +0200
committervertoe2015-10-19 22:52:23 +0200
commit471f111074fdccc9610a666c0234764ef2f109e0 (patch)
treeca439e6c324f813eba7881cffb787c1aec0e3863
parentf514d115244501b0d14f40507265e3e4d311b00d (diff)
downloadaur-471f111074fdccc9610a666c0234764ef2f109e0.tar.gz
Update to new webthree-umbrella repository.
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD83
2 files changed, 89 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b083a292b509..5ccf6326b5ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ethereum
- pkgdesc = Decentralised Consensus-based Deterministic Transaction Resolution Platform
- pkgver = poc.8
+ pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
+ pkgver = 1.0rc2
pkgrel = 1
- url = https://code.ethereum.org
+ url = https://github.com/ethereum/webthree-umbrella
arch = i686
arch = x86_64
groups = ethereum
@@ -12,7 +12,11 @@ pkgbase = ethereum
makedepends = cmake
makedepends = gcc
makedepends = libtool
+ makedepends = v8-3.15
makedepends = yasm
+ makedepends = git
+ makedepends = clang
+ depends = argtable
depends = boost
depends = boost-libs
depends = curl
@@ -20,44 +24,57 @@ pkgbase = ethereum
depends = gmp
depends = jsoncpp
depends = leveldb
- depends = libjson-rpc-cpp-git
+ depends = libedit
+ depends = libjson-rpc-cpp
depends = libmicrohttpd
depends = miniupnpc
depends = ncurses
- depends = nodejs
+ depends = ocl-icd
+ depends = opencl-headers
depends = openssl
depends = python2
depends = qt5-base
depends = qt5-declarative
depends = qt5-quick1
depends = qt5-quickcontrols
+ depends = qt5-webengine
depends = qt5-webkit
depends = readline
depends = snappy
+ depends = llvm
+ depends = scons
+ depends = gperftools
+ provides = alethfive
+ provides = alethone
provides = alethzero
- provides = cpp-ethereum
provides = eth
- provides = ethereum
+ provides = ethkey
+ provides = ethminer
+ provides = ethrpctest
+ provides = ethvm
+ provides = exp
provides = lllc
provides = mix
- provides = neth
- provides = sc
+ provides = rlp
provides = solc
- provides = third
+ provides = ethereum
+ provides = webthree-umbrella
+ conflicts = alethfive
+ conflicts = alethone
conflicts = alethzero
- conflicts = cpp-ethereum
- conflicts = elixir
conflicts = eth
- conflicts = ethereum-serpent
+ conflicts = ethkey
+ conflicts = ethminer
+ conflicts = ethrpctest
+ conflicts = ethvm
+ conflicts = exp
conflicts = lllc
conflicts = mix
- conflicts = neth
- conflicts = sc
- conflicts = secp256k1
+ conflicts = rlp
conflicts = solc
- conflicts = third
- source = ethereum-poc.8.tar.gz::https://codeload.github.com/ethereum/cpp-ethereum/tar.gz/poc-8-tag
- sha256sums = 0d031e90e399d9c59bdc279bfddac2f6a4887f753ba6eb317892669a1825c119
+ conflicts = ethereum-git
+ source = ethereum::git+https://github.com/ethereum/webthree-umbrella
+ sha256sums = SKIP
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index b2fce440871d..5c4672fd26fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,80 +1,103 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Ordoe ordoe <aur@cach.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethereum
-pkgver=poc.8
+pkgver=1.0rc2
pkgrel=1
-pkgdesc="Decentralised Consensus-based Deterministic Transaction Resolution Platform"
+pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
-depends=('boost'
+depends=('argtable'
+ 'boost'
'boost-libs'
'curl'
'crypto++'
'gmp'
'jsoncpp'
'leveldb'
- 'libjson-rpc-cpp-git'
+ 'libedit'
+ 'libjson-rpc-cpp'
'libmicrohttpd'
'miniupnpc'
'ncurses'
- 'nodejs'
+ 'ocl-icd'
+ 'opencl-headers'
'openssl'
'python2'
'qt5-base'
'qt5-declarative'
'qt5-quick1'
'qt5-quickcontrols'
+ 'qt5-webengine'
'qt5-webkit'
'readline'
- 'snappy')
+ 'snappy'
+ 'llvm'
+ 'scons'
+ 'gperftools')
makedepends=('autoconf'
'automake'
'cmake'
'gcc'
'libtool'
- 'yasm')
+ 'v8-3.15'
+ 'yasm'
+ 'git'
+ 'clang')
groups=('ethereum')
-url="https://code.ethereum.org"
+url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/ethereum/cpp-$pkgname/tar.gz/poc-8-tag)
-sha256sums=('0d031e90e399d9c59bdc279bfddac2f6a4887f753ba6eb317892669a1825c119')
-provides=('alethzero'
- 'cpp-ethereum'
+source=(${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella)
+sha256sums=('SKIP')
+provides=('alethfive'
+ 'alethone'
+ 'alethzero'
'eth'
- 'ethereum'
+ 'ethkey'
+ 'ethminer'
+ 'ethrpctest'
+ 'ethvm'
+ 'exp'
'lllc'
'mix'
- 'neth'
- 'sc'
+ 'rlp'
'solc'
- 'third')
-conflicts=('alethzero'
- 'cpp-ethereum'
- 'elixir'
+ 'ethereum'
+ 'webthree-umbrella')
+conflicts=('alethfive'
+ 'alethone'
+ 'alethzero'
'eth'
- 'ethereum-serpent'
+ 'ethkey'
+ 'ethminer'
+ 'ethrpctest'
+ 'ethvm'
+ 'exp'
'lllc'
'mix'
- 'neth'
- 'sc'
- 'secp256k1'
+ 'rlp'
'solc'
- 'third')
+ 'ethereum-git')
build() {
- cd "$srcdir/cpp-$pkgname-poc-8-tag"
+ cd ${pkgname%-git}
+ git checkout $pkgver
+ git submodule update --init --recursive
+
+ # Fix miniupnpc issue in submodule
+ pushd libweb3core
+ git cherry-pick 3ae4d8a
+ popd
msg 'Building...'
mkdir -p build && pushd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DVMTRACE=0 \
- -DEVMJIT=0 # EVMJIT does not compile
+ -DCMAKE_BUILD_TYPE=Release
make
popd
}
package() {
- cd "$srcdir/cpp-$pkgname-poc-8-tag"
+ cd ${pkgname%-git}
msg 'Installing...'
make DESTDIR="$pkgdir" install -C build