summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-01-14 15:40:06 +0100
committer5chdn2016-01-14 15:40:06 +0100
commitcf5b6a083a2a9db7439b8a7c931dfc76f20c28c9 (patch)
treec673227d023b61f534bf046098826e76279539d6
parentf8228d2dc362c1c08fc6d4ffcf17613762a4bf4a (diff)
downloadaur-cf5b6a083a2a9db7439b8a7c931dfc76f20c28c9.tar.gz
Finally fix boost 1.60 issues
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--libethereum-hotfix-boost-1.59.patch18
-rw-r--r--libethereum-hotfix-boost-1.60.patch67
4 files changed, 81 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2098783ef8eb..8c0ff5ff921f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 14:39:20 UTC 2016
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/ethereum/webthree-umbrella
arch = i686
@@ -25,7 +27,7 @@ pkgbase = ethereum
depends = jsoncpp
depends = leveldb
depends = libedit
- depends = libjson-rpc-cpp
+ depends = libjson-rpc-cpp-git
depends = libmicrohttpd
depends = miniupnpc
depends = ncurses
@@ -75,10 +77,10 @@ pkgbase = ethereum
conflicts = solc
conflicts = ethereum-git
source = ethereum::git+https://github.com/ethereum/webthree-umbrella
- source = libethereum-hotfix-boost-1.59.patch
+ source = libethereum-hotfix-boost-1.60.patch
source = solidity-hotfix-boost-1.59.patch
sha256sums = SKIP
- sha256sums = 6c89b82a5b674bb53401a3d87079c415d4d2c28accceb239beeedb940cf213a0
+ sha256sums = fa1edc2b886337b0907122bd4ed4883bf28cc7571e5e5d3dfc0bb6b7637d3848
sha256sums = 3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index 9f3dd10774f7..8e19b1a7c568 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethereum
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ depends=('argtable'
'jsoncpp'
'leveldb'
'libedit'
- 'libjson-rpc-cpp'
+ 'libjson-rpc-cpp-git'
'libmicrohttpd'
'miniupnpc'
'ncurses'
@@ -48,10 +48,10 @@ groups=('ethereum')
url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
- "libethereum-hotfix-boost-1.59.patch"
+ "libethereum-hotfix-boost-1.60.patch"
"solidity-hotfix-boost-1.59.patch")
sha256sums=('SKIP'
- '6c89b82a5b674bb53401a3d87079c415d4d2c28accceb239beeedb940cf213a0'
+ 'fa1edc2b886337b0907122bd4ed4883bf28cc7571e5e5d3dfc0bb6b7637d3848'
'3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2')
provides=('alethfive'
'alethone'
@@ -91,9 +91,9 @@ build() {
git checkout $pkgver
git submodule update --init --recursive
- # Fix libethereum compatibility with boost 1.59
+ # Fix libethereum compatibility with boost 1.59, 1.60
pushd libethereum
- git apply ${srcdir}/libethereum-hotfix-boost-1.59.patch
+ git apply ${srcdir}/libethereum-hotfix-boost-1.60.patch
popd
# Fix solidity compatibility with boost 1.59
@@ -103,7 +103,8 @@ build() {
msg 'Building...'
mkdir -p build && pushd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ CXXFLAGS=-Wno-deprecated-declarations cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make
popd
diff --git a/libethereum-hotfix-boost-1.59.patch b/libethereum-hotfix-boost-1.59.patch
deleted file mode 100644
index 810da7dfbff1..000000000000
--- a/libethereum-hotfix-boost-1.59.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/test/boostTest.cpp b/test/boostTest.cpp
-index 7c2b068..2dc0082 100644
---- a/test/boostTest.cpp
-+++ b/test/boostTest.cpp
-@@ -78,13 +78,6 @@ int main( int argc, char* argv[] )
- {
- framework::init(init_func, argc, argv);
-
-- if( !runtime_config::test_to_run().is_empty() )
-- {
-- test_case_filter filter(runtime_config::test_to_run());
--
-- traverse_test_tree(framework::master_test_suite().p_id, filter);
-- }
--
- framework::run();
-
- results_reporter::make_report();
diff --git a/libethereum-hotfix-boost-1.60.patch b/libethereum-hotfix-boost-1.60.patch
new file mode 100644
index 000000000000..4cbaae6841fe
--- /dev/null
+++ b/libethereum-hotfix-boost-1.60.patch
@@ -0,0 +1,67 @@
+diff --git a/libethcore/Ethash.cpp b/libethcore/Ethash.cpp
+index 0427514..0b3cfbc 100644
+--- a/libethcore/Ethash.cpp
++++ b/libethcore/Ethash.cpp
+@@ -110,7 +110,12 @@ void Ethash::BlockHeaderRaw::verifyParent(BlockHeaderRaw const& _parent)
+ if (m_gasLimit < c_minGasLimit ||
+ m_gasLimit <= _parent.m_gasLimit - _parent.m_gasLimit / c_gasLimitBoundDivisor ||
+ m_gasLimit >= _parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor)
+- BOOST_THROW_EXCEPTION(InvalidGasLimit() << errinfo_min((bigint)_parent.m_gasLimit - _parent.m_gasLimit / c_gasLimitBoundDivisor) << errinfo_got((bigint)m_gasLimit) << errinfo_max((bigint)_parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor));
++ BOOST_THROW_EXCEPTION(
++ InvalidGasLimit()
++ << errinfo_min((bigint)((bigint)_parent.m_gasLimit - (bigint)(_parent.m_gasLimit / c_gasLimitBoundDivisor)))
++ << errinfo_got((bigint)m_gasLimit)
++ << errinfo_max((bigint)((bigint)_parent.m_gasLimit + _parent.m_gasLimit / c_gasLimitBoundDivisor))
++ );
+ }
+
+ void Ethash::BlockHeaderRaw::populateFromParent(BlockHeaderRaw const& _parent)
+diff --git a/test/boostTest.cpp b/test/boostTest.cpp
+index 7c2b068..2e8dbd9 100644
+--- a/test/boostTest.cpp
++++ b/test/boostTest.cpp
+@@ -57,7 +57,7 @@ test_suite* init_func(int argc, char* argv[])
+ //disable post output so the test json would be clean
+ std::cout.rdbuf(strCout.rdbuf());
+ std::cerr.rdbuf(strCout.rdbuf());
+- throw framework::nothing_to_test();
++ exit(0);
+ }
+ }
+ return 0;
+@@ -78,10 +78,19 @@ int main( int argc, char* argv[] )
+ {
+ framework::init(init_func, argc, argv);
+
++#if BOOST_VERSION >= 106000
++ if (true)
++ {
++ test_case_counter filter;
++#elif BOOST_VERSION >= 105900
++ if(!runtime_config::test_to_run().empty())
++ {
++ test_case_counter filter;
++#else
+ if( !runtime_config::test_to_run().is_empty() )
+ {
+ test_case_filter filter(runtime_config::test_to_run());
+-
++#endif
+ traverse_test_tree(framework::master_test_suite().p_id, filter);
+ }
+
+@@ -89,9 +98,14 @@ int main( int argc, char* argv[] )
+
+ results_reporter::make_report();
+
++#if BOOST_VERSION >= 106000
++ return results_collector.results(framework::master_test_suite().p_id).result_code();
++#else
+ return runtime_config::no_result_code()
+ ? boost::exit_success
+ : results_collector.results(framework::master_test_suite().p_id).result_code();
++#endif
++
+ }
+ catch (framework::nothing_to_test const&)
+ {