summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvertoe2015-10-23 22:54:20 +0200
committervertoe2015-10-23 22:54:20 +0200
commitf8228d2dc362c1c08fc6d4ffcf17613762a4bf4a (patch)
treed90ff883cf75ad740cc2d4f72253b15f0b1fe646
parentfffff05bf3c66928097ccd1e2282a2e725b75548 (diff)
downloadaur-f8228d2dc362c1c08fc6d4ffcf17613762a4bf4a.tar.gz
Update version 1.0.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--libethereum-hotfix-boost-1.59.patch13
-rw-r--r--solidity-hotfix-boost-1.59.patch20
4 files changed, 21 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e91a83a3b1e..2098783ef8eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
- pkgver = 1.0rc2
- pkgrel = 3
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/ethereum/webthree-umbrella
arch = i686
arch = x86_64
@@ -78,8 +78,8 @@ pkgbase = ethereum
source = libethereum-hotfix-boost-1.59.patch
source = solidity-hotfix-boost-1.59.patch
sha256sums = SKIP
- sha256sums = 27efde29e731b48d78bda8036edbb765c1980ef83d815bcc2985921a31bd0389
- sha256sums = 11d47542cb7129dd09cd7336655734ccdb2c940cdf30bcb5e755faeeeb6470ff
+ sha256sums = 6c89b82a5b674bb53401a3d87079c415d4d2c28accceb239beeedb940cf213a0
+ sha256sums = 3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index a6d08833d451..9f3dd10774f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethereum
-pkgver=1.0rc2
-pkgrel=3
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
depends=('argtable'
@@ -51,8 +51,8 @@ source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
"libethereum-hotfix-boost-1.59.patch"
"solidity-hotfix-boost-1.59.patch")
sha256sums=('SKIP'
- '27efde29e731b48d78bda8036edbb765c1980ef83d815bcc2985921a31bd0389'
- '11d47542cb7129dd09cd7336655734ccdb2c940cdf30bcb5e755faeeeb6470ff')
+ '6c89b82a5b674bb53401a3d87079c415d4d2c28accceb239beeedb940cf213a0'
+ '3d1e45a59c1f9c22564bb04d0aebacb74bffa3c7d72dc475429afb827c8be4f2')
provides=('alethfive'
'alethone'
'alethzero'
@@ -84,17 +84,13 @@ conflicts=('alethfive'
'ethereum-git')
build() {
+
+ msg 'Updating...'
cd ${pkgname%-git}
git checkout release
git checkout $pkgver
git submodule update --init --recursive
- msg 'Patching...'
- # Fix libweb3core compatibility with latest miniupnpc
- pushd libweb3core
- git cherry-pick 3ae4d8a
- popd
-
# Fix libethereum compatibility with boost 1.59
pushd libethereum
git apply ${srcdir}/libethereum-hotfix-boost-1.59.patch
@@ -118,4 +114,8 @@ package() {
msg 'Installing...'
make DESTDIR="$pkgdir" install -C build
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
}
diff --git a/libethereum-hotfix-boost-1.59.patch b/libethereum-hotfix-boost-1.59.patch
index 166fbe2b78bd..810da7dfbff1 100644
--- a/libethereum-hotfix-boost-1.59.patch
+++ b/libethereum-hotfix-boost-1.59.patch
@@ -1,8 +1,8 @@
diff --git a/test/boostTest.cpp b/test/boostTest.cpp
-index 7c2b068..a883d85 100644
+index 7c2b068..2dc0082 100644
--- a/test/boostTest.cpp
+++ b/test/boostTest.cpp
-@@ -78,12 +78,12 @@ int main( int argc, char* argv[] )
+@@ -78,13 +78,6 @@ int main( int argc, char* argv[] )
{
framework::init(init_func, argc, argv);
@@ -12,12 +12,7 @@ index 7c2b068..a883d85 100644
-
- traverse_test_tree(framework::master_test_suite().p_id, filter);
- }
-+// if( !runtime_config::test_to_run().is_empty() )
-+// {
-+// test_case_filter filter(runtime_config::test_to_run());
-+//
-+// traverse_test_tree(framework::master_test_suite().p_id, filter);
-+// }
-
+-
framework::run();
+ results_reporter::make_report();
diff --git a/solidity-hotfix-boost-1.59.patch b/solidity-hotfix-boost-1.59.patch
index 92eefede1cff..880a61e20d80 100644
--- a/solidity-hotfix-boost-1.59.patch
+++ b/solidity-hotfix-boost-1.59.patch
@@ -1,8 +1,8 @@
diff --git a/test/TestHelper.h b/test/TestHelper.h
-index 0bf6222..acb3a4f 100644
+index 0bf6222..94b5ee2 100644
--- a/test/TestHelper.h
+++ b/test/TestHelper.h
-@@ -46,13 +46,13 @@ namespace test
+@@ -46,12 +46,6 @@ namespace test
{ \
auto msg = std::string(_message " due to an exception thrown by " \
BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
@@ -12,17 +12,10 @@ index 0bf6222..acb3a4f 100644
- { \
- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
- BOOST_STRINGIZE(_statement), REQUIRE, CHECK_MSG); \
-+/* BOOST_CHECK_IMPL(false, msg, REQUIRE, CHECK_MSG); \ */
} \
-+/* catch (...) \ */
-+/* { \ */
-+/* BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \ */
-+/* BOOST_STRINGIZE(_statement), REQUIRE, CHECK_MSG); \ */
-+/* } \ */
} \
while (0)
-
-@@ -72,13 +72,13 @@ namespace test
+@@ -72,12 +66,6 @@ namespace test
{ \
auto msg = std::string(_message " due to an exception thrown by " \
BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
@@ -32,13 +25,6 @@ index 0bf6222..acb3a4f 100644
- { \
- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
- BOOST_STRINGIZE(_statement), CHECK, CHECK_MSG ); \
-+/* BOOST_CHECK_IMPL(false, msg, CHECK, CHECK_MSG); \ */
} \
-+/* catch (...) \ */
-+/* { \ */
-+/* BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \ */
-+/* BOOST_STRINGIZE(_statement), CHECK, CHECK_MSG ); \ */
-+/* } \ */
} \
while (0)
-