summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvertoe2015-10-23 16:11:58 +0200
committervertoe2015-10-23 16:11:58 +0200
commitfffff05bf3c66928097ccd1e2282a2e725b75548 (patch)
tree0a6a2a6eb611655a02702225c6e39384ecf5edec
parente2d8f81deb12829c2e62d1d2a9f1071054de562b (diff)
downloadaur-fffff05bf3c66928097ccd1e2282a2e725b75548.tar.gz
Add patches for boost incomp workarounds
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--libethereum-hotfix-boost-1.59.patch23
-rw-r--r--solidity-hotfix-boost-1.59.patch44
4 files changed, 96 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0912d97951de..0e91a83a3b1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ethereum
pkgdesc = Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)
pkgver = 1.0rc2
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/ethereum/webthree-umbrella
arch = i686
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = ethereum
makedepends = git
makedepends = clang
depends = argtable
- depends = boost<=1.58
- depends = boost-libs<=1.58
+ depends = boost
+ depends = boost-libs
depends = curl
depends = crypto++
depends = gmp
@@ -75,7 +75,11 @@ pkgbase = ethereum
conflicts = solc
conflicts = ethereum-git
source = ethereum::git+https://github.com/ethereum/webthree-umbrella
+ source = libethereum-hotfix-boost-1.59.patch
+ source = solidity-hotfix-boost-1.59.patch
sha256sums = SKIP
+ sha256sums = 27efde29e731b48d78bda8036edbb765c1980ef83d815bcc2985921a31bd0389
+ sha256sums = 11d47542cb7129dd09cd7336655734ccdb2c940cdf30bcb5e755faeeeb6470ff
pkgname = ethereum
diff --git a/PKGBUILD b/PKGBUILD
index fd649c9d19ef..a6d08833d451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=ethereum
pkgver=1.0rc2
-pkgrel=2
+pkgrel=3
pkgdesc="Ethereum decentralised consensus-based deterministic transaction resolution platform (C++ toolkit, full webthree-umbrella)"
arch=('i686' 'x86_64')
depends=('argtable'
- 'boost<=1.58'
- 'boost-libs<=1.58'
+ 'boost'
+ 'boost-libs'
'curl'
'crypto++'
'gmp'
@@ -47,8 +47,12 @@ makedepends=('autoconf'
groups=('ethereum')
url="https://github.com/ethereum/webthree-umbrella"
license=('GPL')
-source=(${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella)
-sha256sums=('SKIP')
+source=("${pkgname%-git}::git+https://github.com/ethereum/webthree-umbrella"
+ "libethereum-hotfix-boost-1.59.patch"
+ "solidity-hotfix-boost-1.59.patch")
+sha256sums=('SKIP'
+ '27efde29e731b48d78bda8036edbb765c1980ef83d815bcc2985921a31bd0389'
+ '11d47542cb7129dd09cd7336655734ccdb2c940cdf30bcb5e755faeeeb6470ff')
provides=('alethfive'
'alethone'
'alethzero'
@@ -81,14 +85,26 @@ conflicts=('alethfive'
build() {
cd ${pkgname%-git}
+ git checkout release
git checkout $pkgver
git submodule update --init --recursive
- # Fix miniupnpc issue in submodule
+ msg 'Patching...'
+ # Fix libweb3core compatibility with latest miniupnpc
pushd libweb3core
git cherry-pick 3ae4d8a
popd
+ # Fix libethereum compatibility with boost 1.59
+ pushd libethereum
+ git apply ${srcdir}/libethereum-hotfix-boost-1.59.patch
+ popd
+
+ # Fix solidity compatibility with boost 1.59
+ pushd solidity
+ git apply ${srcdir}/solidity-hotfix-boost-1.59.patch
+ popd
+
msg 'Building...'
mkdir -p build && pushd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
diff --git a/libethereum-hotfix-boost-1.59.patch b/libethereum-hotfix-boost-1.59.patch
new file mode 100644
index 000000000000..166fbe2b78bd
--- /dev/null
+++ b/libethereum-hotfix-boost-1.59.patch
@@ -0,0 +1,23 @@
+diff --git a/test/boostTest.cpp b/test/boostTest.cpp
+index 7c2b068..a883d85 100644
+--- a/test/boostTest.cpp
++++ b/test/boostTest.cpp
+@@ -78,12 +78,12 @@ int main( int argc, char* argv[] )
+ {
+ framework::init(init_func, argc, argv);
+
+- if( !runtime_config::test_to_run().is_empty() )
+- {
+- test_case_filter filter(runtime_config::test_to_run());
+-
+- traverse_test_tree(framework::master_test_suite().p_id, filter);
+- }
++// if( !runtime_config::test_to_run().is_empty() )
++// {
++// test_case_filter filter(runtime_config::test_to_run());
++//
++// traverse_test_tree(framework::master_test_suite().p_id, filter);
++// }
+
+ framework::run();
+
diff --git a/solidity-hotfix-boost-1.59.patch b/solidity-hotfix-boost-1.59.patch
new file mode 100644
index 000000000000..92eefede1cff
--- /dev/null
+++ b/solidity-hotfix-boost-1.59.patch
@@ -0,0 +1,44 @@
+diff --git a/test/TestHelper.h b/test/TestHelper.h
+index 0bf6222..acb3a4f 100644
+--- a/test/TestHelper.h
++++ b/test/TestHelper.h
+@@ -46,13 +46,13 @@ namespace test
+ { \
+ auto msg = std::string(_message " due to an exception thrown by " \
+ BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
+- BOOST_CHECK_IMPL(false, msg, REQUIRE, CHECK_MSG); \
+- } \
+- catch (...) \
+- { \
+- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
+- BOOST_STRINGIZE(_statement), REQUIRE, CHECK_MSG); \
++/* BOOST_CHECK_IMPL(false, msg, REQUIRE, CHECK_MSG); \ */
+ } \
++/* catch (...) \ */
++/* { \ */
++/* BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \ */
++/* BOOST_STRINGIZE(_statement), REQUIRE, CHECK_MSG); \ */
++/* } \ */
+ } \
+ while (0)
+
+@@ -72,13 +72,13 @@ namespace test
+ { \
+ auto msg = std::string(_message " due to an exception thrown by " \
+ BOOST_STRINGIZE(_statement) "\n") + boost::diagnostic_information(_e); \
+- BOOST_CHECK_IMPL(false, msg, CHECK, CHECK_MSG); \
+- } \
+- catch (...) \
+- { \
+- BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \
+- BOOST_STRINGIZE(_statement), CHECK, CHECK_MSG ); \
++/* BOOST_CHECK_IMPL(false, msg, CHECK, CHECK_MSG); \ */
+ } \
++/* catch (...) \ */
++/* { \ */
++/* BOOST_CHECK_IMPL(false, "Unknown exception thrown by " \ */
++/* BOOST_STRINGIZE(_statement), CHECK, CHECK_MSG ); \ */
++/* } \ */
+ } \
+ while (0)
+