summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2015-10-23 21:11:55 +0200
committerRubenKelevra2015-10-23 21:11:55 +0200
commitf72eec8ee730880c57fc222a3fdee3d4f573c62e (patch)
tree7e2ff98e28ec2f1cafbe0df14c0e0fb72c874600
parentb65d14f656c0a302ac25d3347766c001ede4e9f6 (diff)
downloadaur-f72eec8ee730880c57fc222a3fdee3d4f573c62e.tar.gz
add fix for nodejs v4.x
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
-rw-r--r--fix-v4.x-nodejs.patch14
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 875e4239bf74..764b0b766717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = etherpad-lite
pkgdesc = Lightweight fork of etherpad based on javascript
pkgver = 1.5.7
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://etherpad.org
install = etherpad-lite.install
@@ -10,7 +10,7 @@ pkgbase = etherpad-lite
depends = curl
depends = python2
depends = openssl
- depends = nodejs<0.13.0
+ depends = nodejs<5
depends = git
depends = npm
optdepends = sqlite: to use sqlite as databse
@@ -21,8 +21,10 @@ pkgbase = etherpad-lite
backup = etc/webapps/etherpad-lite/settings.json
source = etherpad-lite-1.5.7.tar.gz::https://github.com/ether/etherpad-lite/archive/1.5.7.tar.gz
source = etherpad-lite.service
+ source = fix-v4.x-nodejs.patch
sha512sums = 688205194347f0e4e6f78deb0b189ceaa4f2255efcbaa503d0b6459de8505dd475aa9151399dd818b6cac232bc0b71e5a0fbd6d43f56cb5ce1f9eafcccb3925b
sha512sums = 7b775171da97a3e7ad44a2b1b319970fd307a88e90a171c49bf70d2382767175e98bb21c7054e38ee6c066bd2dfadf94d28a9ff31d4f21145ec4441caa13c4d7
+ sha512sums = f52a204b2879369e230190edb59b3704ae7f7ed8ff41ebfe8e8ffd42c3686148716ee9e04c0ffc417498c44a4a8753f621f7cc2fbfce99171d20c5fe1a0cfc27
pkgname = etherpad-lite
diff --git a/PKGBUILD b/PKGBUILD
index c510ab45d386..aac704a752b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=etherpad-lite
pkgver=1.5.7
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Lightweight fork of etherpad based on javascript"
arch=(any)
url="http://etherpad.org"
_watch=('http://etherpad.org','Documentation <small>v([\d.]*)</small>')
license=('GPL2')
-depends=('curl' 'python2' 'openssl' 'nodejs<0.13.0' 'git' 'npm')
+depends=('curl' 'python2' 'openssl' 'nodejs<5' 'git' 'npm')
optdepends=('sqlite: to use sqlite as databse'
'mariadb: to use mariadb as database'
'postgresql: to use postgresql as database')
@@ -19,12 +19,22 @@ backup=('usr/share/webapps/etherpad-lite/settings.json'
'etc/webapps/etherpad-lite/settings.json')
install='etherpad-lite.install'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ether/${pkgname}/archive/${pkgver}.tar.gz"
- "etherpad-lite.service")
+ "etherpad-lite.service"
+ "fix-v4.x-nodejs.patch")
sha512sums=('688205194347f0e4e6f78deb0b189ceaa4f2255efcbaa503d0b6459de8505dd475aa9151399dd818b6cac232bc0b71e5a0fbd6d43f56cb5ce1f9eafcccb3925b'
- '7b775171da97a3e7ad44a2b1b319970fd307a88e90a171c49bf70d2382767175e98bb21c7054e38ee6c066bd2dfadf94d28a9ff31d4f21145ec4441caa13c4d7')
+ '7b775171da97a3e7ad44a2b1b319970fd307a88e90a171c49bf70d2382767175e98bb21c7054e38ee6c066bd2dfadf94d28a9ff31d4f21145ec4441caa13c4d7'
+ 'f52a204b2879369e230190edb59b3704ae7f7ed8ff41ebfe8e8ffd42c3686148716ee9e04c0ffc417498c44a4a8753f621f7cc2fbfce99171d20c5fe1a0cfc27')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ for s in "${source[@]}"; do
+ case "$s" in (*.patch)
+ cp "../${s}" .
+ patch -p0 < "${s}"
+ rm -f "${s}"
+ esac
+ done
}
build() {
diff --git a/fix-v4.x-nodejs.patch b/fix-v4.x-nodejs.patch
new file mode 100644
index 000000000000..1692adaa7156
--- /dev/null
+++ b/fix-v4.x-nodejs.patch
@@ -0,0 +1,14 @@
+--- ./bin/installDeps.sh 2015-10-23 20:53:47.956110304 +0200
++++ ./bin/installDeps.sh 2015-10-23 20:51:18.829811105 +0200
+@@ -50,9 +50,9 @@
+ if hash iojs 2>/dev/null; then
+ IOJS_VERSION=$(iojs --version)
+ fi
+-if [ ! $NODE_V_MINOR = "v0.10" ] && [ ! $NODE_V_MINOR = "v0.11" ] && [ ! $NODE_V_MINOR = "v0.12" ]; then
++if [ ! ${NODE_V_MINOR:0:3} = "v4." ] && [ ! $NODE_V_MINOR = "v0.10" ] && [ ! $NODE_V_MINOR = "v0.11" ] && [ ! $NODE_V_MINOR = "v0.12" ]; then
+ if [ ! $IOJS_VERSION ]; then
+- echo "You're running a wrong version of node, or io.js is not installed. You're using $NODE_VERSION, we need v0.10.x, v0.11.x or v0.12.x" >&2
++ echo "You're running a wrong version of node, or io.js is not installed. You're using $NODE_VERSION, we need v4.x, v0.10.x, v0.11.x or v0.12.x" >&2
+ exit 1
+ fi
+ fi