summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraimileus2018-01-24 11:12:35 +0100
committeraimileus2018-01-24 11:13:16 +0100
commita1b6bd8bec777ec65f7fd45ea8de36d1dbf16605 (patch)
treea83c1dcea64c2f5548f794082840e472a47893e7
parentead74426213549af91a8b22541f6d2d371b35cdb (diff)
downloadaur-a1b6bd8bec777ec65f7fd45ea8de36d1dbf16605.tar.gz
ethminer - update to 0.13.0 and build from source
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD63
2 files changed, 42 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b40523cdcd8..485ec3526d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Aug 31 08:15:09 UTC 2017
pkgbase = ethminer
pkgdesc = Ethereum miner with OpenCL, CUDA and stratum support.
- pkgver = 0.12.0.dev2
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/ethereum-mining/ethminer
arch = x86_64
license = MIT
- depends = boost
- depends = boost-libs
- depends = jsoncpp
- depends = libjson-rpc-cpp-git
- depends = opencl-headers
- depends = python2
- provides = ethminer
+ makedepends = cmake
+ makedepends = python
+ depends = mesa
+ optdepends = cuda: NVIDIA cuda mining support
conflicts = ethereum
- conflicts = ethminer-git
- conflicts = ethereum-git
- source = https://github.com/ethereum-mining/ethminer/releases/download/v0.12.0.dev2/ethminer-0.12.0.dev2-Linux.tar.gz
- sha256sums = e2b6f595c76075549ca59ba239d26b96d0bd6d886441c3fd16e0e0975777aed7
+ source = https://github.com/ethereum-mining/ethminer/archive/v0.13.0.tar.gz
+ sha256sums = 72bf827a922b797d556f8f03980185c4857bb82074b4c8b5f63b5d5e140893b8
pkgname = ethminer
diff --git a/PKGBUILD b/PKGBUILD
index 4261088f0532..77871014ba1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,47 @@
-# Maintainer: Afri 5chdn <aur@5chdn.co>
+# Maintainer: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d) >
+# Contributor: Afri 5chdn <aur@5chdn.co>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethminer
-pkgver=0.12.0.dev2
+pkgver=0.13.0
pkgrel=1
pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
arch=('x86_64')
-depends=(
- 'boost'
- 'boost-libs'
- 'jsoncpp'
- 'libjson-rpc-cpp-git'
- 'opencl-headers'
- 'python2'
-)
-optdeps=(
- 'cuda: NVIDEA GPU mining support.'
- 'opencl-mesa: AMD/ATI GPU mining support.'
-)
url="https://github.com/ethereum-mining/ethminer"
license=('MIT')
-source=(
- "https://github.com/ethereum-mining/ethminer/releases/download/v${pkgver}/ethminer-${pkgver}-Linux.tar.gz"
-)
-sha256sums=(
- 'e2b6f595c76075549ca59ba239d26b96d0bd6d886441c3fd16e0e0975777aed7'
-)
-provides=(
- 'ethminer'
-)
-conflicts=(
- 'ethereum'
- 'ethminer-git'
- 'ethereum-git'
+depends=('mesa')
+makedepends=(
+ 'cmake'
+ 'python'
)
+optdepends=('cuda: NVIDIA cuda mining support')
+conflicts=('ethereum')
+source=("https://github.com/ethereum-mining/ethminer/archive/v${pkgver}.tar.gz")
+sha256sums=('72bf827a922b797d556f8f03980185c4857bb82074b4c8b5f63b5d5e140893b8')
+
+build () {
+
+ cd $pkgname-$pkgver
+ mkdir -p build && cd build
+
+ if [ -f '/opt/cuda/bin/nvcc' ]; then
+ export CC=gcc-6
+ export CCX=g++-6
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DETHASHCUDA=ON
+ else
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ fi
+
+ make
+}
+
package() {
- install -Dm755 -t "${pkgdir}"/usr/bin ${srcdir}/bin/ethminer
+ cd $pkgname-$pkgver/build
+ make DESTDIR=$pkgdir install
}