summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2017-08-31 10:15:24 +0200
committer5chdn2017-08-31 10:15:24 +0200
commitead74426213549af91a8b22541f6d2d371b35cdb (patch)
tree034211d6dc0cd09d7d4d3e91c7db385039ca757b
downloadaur-ead74426213549af91a8b22541f6d2d371b35cdb.tar.gz
Initial version.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b40523cdcd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Aug 31 08:15:09 UTC 2017
+pkgbase = ethminer
+ pkgdesc = Ethereum miner with OpenCL, CUDA and stratum support.
+ pkgver = 0.12.0.dev2
+ pkgrel = 1
+ url = https://github.com/ethereum-mining/ethminer
+ arch = x86_64
+ license = MIT
+ depends = boost
+ depends = boost-libs
+ depends = jsoncpp
+ depends = libjson-rpc-cpp-git
+ depends = opencl-headers
+ depends = python2
+ provides = ethminer
+ conflicts = ethereum
+ conflicts = ethminer-git
+ conflicts = ethereum-git
+ source = https://github.com/ethereum-mining/ethminer/releases/download/v0.12.0.dev2/ethminer-0.12.0.dev2-Linux.tar.gz
+ sha256sums = e2b6f595c76075549ca59ba239d26b96d0bd6d886441c3fd16e0e0975777aed7
+
+pkgname = ethminer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4261088f0532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Afri 5chdn <aur@5chdn.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=ethminer
+pkgver=0.12.0.dev2
+pkgrel=1
+pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
+arch=('x86_64')
+depends=(
+ 'boost'
+ 'boost-libs'
+ 'jsoncpp'
+ 'libjson-rpc-cpp-git'
+ 'opencl-headers'
+ 'python2'
+)
+optdeps=(
+ 'cuda: NVIDEA GPU mining support.'
+ 'opencl-mesa: AMD/ATI GPU mining support.'
+)
+url="https://github.com/ethereum-mining/ethminer"
+license=('MIT')
+source=(
+ "https://github.com/ethereum-mining/ethminer/releases/download/v${pkgver}/ethminer-${pkgver}-Linux.tar.gz"
+)
+sha256sums=(
+ 'e2b6f595c76075549ca59ba239d26b96d0bd6d886441c3fd16e0e0975777aed7'
+)
+provides=(
+ 'ethminer'
+)
+conflicts=(
+ 'ethereum'
+ 'ethminer-git'
+ 'ethereum-git'
+)
+
+package() {
+ install -Dm755 -t "${pkgdir}"/usr/bin ${srcdir}/bin/ethminer
+}