summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSmasher8162017-06-30 20:25:28 -0700
committerSmasher8162017-06-30 20:25:28 -0700
commitf0f8047e006f3f47710f7badae08deb52fa00c38 (patch)
tree69be02974c062cb105526690bebd751baceb9325
downloadaur-f0f8047e006f3f47710f7badae08deb52fa00c38.tar.gz
Create package
Adopted from the ethereum-genoil-git PKGBUILD
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD81
2 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9816a9da26a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = ethminer-git
+ pkgdesc = Ethereum miner with CUDA and stratum support. chfast's version.
+ pkgver = 0.11.0.0.20170630.7b678d8a4
+ pkgrel = 1
+ url = https://github.com/ethereum-mining/ethminer
+ arch = i686
+ arch = x86_64
+ groups = ethereum
+ license = GPL
+ makedepends = gcc5
+ makedepends = cmake
+ makedepends = git
+ makedepends = opencl-headers
+ depends = boost
+ depends = crypto++
+ depends = cuda
+ depends = leveldb
+ depends = ocl-icd
+ depends = libmicrohttpd
+ depends = miniupnpc
+ depends = libjson-rpc-cpp-git
+ optdepends = solidity: The Solidity Contract-Oriented Programming Language
+ provides = ethminer
+ conflicts = ethminer
+ conflicts = ethereum
+ conflicts = ethereum-git
+ conflicts = cpp-ethereum
+ source = ethminer-git::git+https://github.com/ethereum-mining/ethminer
+ sha256sums = SKIP
+
+pkgname = ethminer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd870d55baf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Rowan Decker <rdecker@scu.edu>
+# Contributor: Eric Toombs <ee double you toombs at you waterloo dot see eh?>
+# Contributor: Afri 5chdn <aur@cach.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=ethminer-git
+pkgver=0.11.0.0.20170630.7b678d8a4
+pkgrel=1
+pkgdesc="Ethereum miner with CUDA and stratum support. chfast's version."
+arch=('i686' 'x86_64')
+depends=(
+ 'boost'
+ 'crypto++'
+ 'cuda'
+ 'leveldb'
+ 'ocl-icd'
+ 'libmicrohttpd'
+ 'miniupnpc'
+ 'libjson-rpc-cpp-git'
+)
+makedepends=(
+ 'gcc5'
+ 'cmake'
+ 'git'
+ 'opencl-headers'
+)
+optdepends=(
+ 'solidity: The Solidity Contract-Oriented Programming Language'
+)
+groups=('ethereum')
+url="https://github.com/ethereum-mining/ethminer"
+license=('GPL')
+source=(
+ "$pkgname::git+https://github.com/ethereum-mining/ethminer"
+)
+sha256sums=(
+ "SKIP"
+)
+provides=(
+ 'ethminer'
+)
+conflicts=(
+ 'ethminer'
+ 'ethereum'
+ 'ethereum-git'
+ 'cpp-ethereum'
+)
+
+pkgver() {
+ cd "$pkgname"
+ echo "`grep -m1 "PROJECT_VERSION" CMakeLists.txt | tr -cd '[[:digit:]].'`.`date +%Y%m%d`.`git log --pretty=format:%h -n 1`"
+}
+
+build() {
+ msg 'Updating...'
+ cd "$pkgname"
+ git submodule update --init --recursive
+
+ msg 'Building...'
+ mkdir -p build && pushd build
+ unset CFLAGS #march=native can break the build if set in makepkg.conf
+ unset CXXFLAGS
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DETHASHCUDA=ON \
+ -DCMAKE_C_COMPILER=/usr/bin/gcc-5 \
+ -DCMAKE_CXX_COMPILER=/usr/bin/g++-5 \
+ -DCMAKE_RANLIB=/usr/bin/gcc-ranlib-5 \
+ -DCMAKE_AR=/usr/bin/gcc-ar-5
+ cmake --build .
+ popd
+}
+
+package() {
+ cd "$pkgname"
+
+ msg 'Installing...'
+ make DESTDIR="$pkgdir" install -C build
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}