summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorggilestro2019-07-02 13:13:01 +0100
committerggilestro2019-07-02 13:13:01 +0100
commit4e13f0aabc454e99c925688bc00cde9cc7e68818 (patch)
tree463835ec830bf2ed85e303da8b4cdaff11e56525
parent8c123241884651700bdffe99ee2527ca445c9180 (diff)
downloadaur-4e13f0aabc454e99c925688bc00cde9cc7e68818.tar.gz
Repeating the pip install process in the post install hook
Adding hostname to the /etc/hosts file
-rw-r--r--ethoscope-node.install7
1 files changed, 6 insertions, 1 deletions
diff --git a/ethoscope-node.install b/ethoscope-node.install
index d3c96a013f88..b38ff9fe767b 100644
--- a/ethoscope-node.install
+++ b/ethoscope-node.install
@@ -12,13 +12,18 @@ post_install() {
#setting branch
git checkout python3.7
+ #installing python module
+ cd /opt/ethoscope-node/node_src/
+ python setup.py install
+
echo "enabling NODE specific systemd service files"
systemctl enable ethoscope_node.service ethoscope_update_node.service ethoscope_backup.service ethoscope_video_backup.service
echo "enabling the GIT server on the node"
systemctl enable git-daemon.socket
#changing hostname on node
- echo "node" > /etc/hostname
+ hostnamectl set-hostname node
+ echo "127.0.0.1 node" > /etc/hosts
#PLEASE REBOOT NOW.
}