summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2020-10-29 13:47:18 +0000
committerGiorgio Gilestro2020-10-29 13:47:18 +0000
commitb22872b1828e99623cc20650c223a0f36127ce4e (patch)
tree71667ca4ae41e07cf5cdff1f08fe7422fe737df2
parent20c9ccb965a2ef16897153cbbd71b6a35edd72a8 (diff)
downloadaur-b22872b1828e99623cc20650c223a0f36127ce4e.tar.gz
Adjust post-installation hooks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c791ea155ef..cb60007ada2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ethoscope-node
pkgdesc = A platform for monitoring animal behaviour in real time from a raspberry pi
- pkgver = 1
+ pkgver = r1969.g0521648
pkgrel = 1
url = http://lab.gilest.ro/ethoscope
install = ethoscope-node.install
diff --git a/PKGBUILD b/PKGBUILD
index db60641b365a..7d76128fb393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Giorgio Gilestro <giorgio at gilest.ro>
pkgname=ethoscope-node
-pkgver=0.0.0
+pkgver=r1969.g0521648
pkgrel=1
pkgdesc="A platform for monitoring animal behaviour in real time from a raspberry pi"
arch=('any')
@@ -11,13 +11,12 @@ makedepends=('git' 'gcc-fortran' 'rsync' 'wget' 'fping' )
depends=('ntp' 'openssh' 'mariadb' 'dnsmasq' 'avahi' 'python-setuptools' 'python-pip' 'python-ifaddr' 'python-numpy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-zeroconf' 'python-cheroot')
provides=('ethoscope')
install="ethoscope-node.install"
-source=("$pkgname::git://github.com/gilestrolab/ethoscope.git")
+source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- # Use the tag of the last commit
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$pkgname"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
@@ -32,13 +31,17 @@ package() {
#setting python3 branch
cd "${srcdir}/${pkgname}"
- git checkout python3.7
+ git checkout dev
#cp node server and node updater
cd "${srcdir}"
cp -R --no-dereference --preserve=mode,links -v * "${pkgdir}/opt/${pkgname}"
ln -s /opt/ethoscope-node/scripts/ethoscope_updater "${pkgdir}/opt/"
+ #changing the remote GIT source to local BARE created during installation
+ cd "${pkgdir}/opt/${pkgname}"
+ git remote set-url origin /srv/git/ethoscope.git
+
#install python service
#cd "${srcdir}/${pkgname}/node_src"
#pip install -e . --install-option="--prefix=${pkgdir}" --no-deps