summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2018-12-09 17:39:10 +0100
committerJulian Xhokaxhiu2018-12-09 17:39:10 +0100
commit341d456ae6fe5d67ca94a00ec5528ab8aaabc472 (patch)
tree79b0a7b6cd7b4f26331076c575212ea56accb51b
downloadaur-341d456ae6fe5d67ca94a00ec5528ab8aaabc472.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD35
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13d307956d44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ethr-git
+ pkgdesc = Ethr is a Network Performance Measurement Tool for TCP, UDP & HTTP
+ pkgver = v0.1.r17.gb979b9c
+ pkgrel = 1
+ url = https://github.com/Microsoft/Ethr
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = ethr-git::git+https://github.com/Microsoft/Ethr
+ sha256sums = SKIP
+
+pkgname = ethr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31b3675bb091
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# ...but
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f84b60255d4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
+pkgname=ethr-git
+pkgver=v0.1.r17.gb979b9c
+pkgrel=1
+pkgdesc="Ethr is a Network Performance Measurement Tool for TCP, UDP & HTTP"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/Microsoft/Ethr"
+license=('MIT')
+makedepends=(
+ 'go'
+ 'git'
+)
+source=("${pkgname}::git+https://github.com/Microsoft/Ethr")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ # Install deps
+ go get github.com/nsf/termbox-go
+
+ # Build
+ go build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/ethr"
+}