summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:53:52 +0200
committerChristian Hesse2015-06-29 09:53:52 +0200
commit3737dcd33d67659bf67d092b699fedf609172fd8 (patch)
tree3f1dc7d5a67dedc1d644fb97a6abfdb4610dbf86
downloadaur-3737dcd33d67659bf67d092b699fedf609172fd8.tar.gz
initial import of ethstatus 0.4.3-5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27a8b6b441f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ethstatus
+ pkgdesc = A simple program for displaying commonly needed/wanted statistics in real time of incoming and outgoing traffic
+ pkgver = 0.4.3
+ pkgrel = 5
+ url = http://packages.qa.debian.org/e/ethstatus.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ source = http://ftp.debian.org/debian/pool/main/e/ethstatus/ethstatus_0.4.3.tar.gz
+ sha256sums = deeecee351dc5cfa309a9130e53ee619a0f0228fc633f60751ad5b2266774399
+
+pkgname = ethstatus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65512733c754
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=ethstatus
+pkgver=0.4.3
+pkgrel=5
+pkgdesc='A simple program for displaying commonly needed/wanted statistics in real time of incoming and outgoing traffic'
+arch=('i686' 'x86_64')
+url='http://packages.qa.debian.org/e/ethstatus.html'
+license=('GPL')
+depends=('ncurses')
+source=("http://ftp.debian.org/debian/pool/main/e/${pkgname}/${pkgname}_${pkgver}.tar.gz")
+sha256sums=('deeecee351dc5cfa309a9130e53ee619a0f0228fc633f60751ad5b2266774399')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -D -m0755 ethstatus "${pkgdir}/usr/bin/ethstatus"
+ install -D -m0644 ethstatus.1 "${pkgdir}/usr/share/man/man1/ethstatus.1"
+}
+