summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-25 09:43:05 +0800
committerChocobo12017-08-25 09:47:12 +0800
commitd77ff76557ea4dfeaec28bf296e530427a169abf (patch)
treea7bf99adbf8bdbfd1365e6425df401903aaa9a55
downloadaur-d77ff76557ea4dfeaec28bf296e530427a169abf.tar.gz
newpkg: ethtool-git 4.10.r9.gb888f35-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1613fbef2124
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ethtool-git
+ pkgdesc = Utility for controlling network drivers and hardware
+ pkgver = 4.10.r9.gb888f35
+ pkgrel = 1
+ url = https://www.kernel.org/pub/software/network/ethtool/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ provides = ethtool
+ conflicts = ethtool
+ source = git+https://git.kernel.org/pub/scm/network/ethtool/ethtool.git
+ sha256sums = SKIP
+
+pkgname = ethtool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ce179e710c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=ethtool-git
+pkgver=4.10.r9.gb888f35
+pkgrel=1
+pkgdesc="Utility for controlling network drivers and hardware"
+arch=('i686' 'x86_64')
+url="https://www.kernel.org/pub/software/network/ethtool/"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=('ethtool')
+conflicts=('ethtool')
+source=("git+https://git.kernel.org/pub/scm/network/ethtool/ethtool.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "ethtool"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "ethtool"
+
+ ./autogen.sh
+ ./configure --prefix="/usr" --sbindir="/usr/bin"
+ make
+}
+
+check() {
+ cd "ethtool"
+
+ make check
+}
+
+package() {
+ cd "ethtool"
+
+ make DESTDIR="$pkgdir" install
+}