summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-08-17 05:33:23 +0300
committerArtem Vorotnikov2015-08-17 05:33:23 +0300
commitf225a308ae22ac6a476f3fb17e905dacbd82c469 (patch)
tree5e2c00624c4db53d6a3a0908f5f349ba16de6d24
parent8d2ffe0a986d28433d8eb0473ae467d845cbbe20 (diff)
downloadaur-f225a308ae22ac6a476f3fb17e905dacbd82c469.tar.gz
New version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b69d24c48d2c..9ee080351323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = etlegacy-git
- pkgver = LATEST
+ pkgver = 2.73.91.ga1d3419
pkgrel = 1
url = http://etlegacy.com/
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
@@ -41,8 +40,6 @@ pkgname = etlegacy-git
backup = etc/xdg/etlegacy/etmain/lmscycle.cfg
backup = etc/xdg/etlegacy/etmain/mapvotecycle.cfg
backup = etc/xdg/etlegacy/etmain/objectivecycle.cfg
- conflicts_x86_64 = etlegacy64-git
- replaces_x86_64 = etlegacy64-git
pkgname = etlegacy-mod-git
pkgdesc = Wolfenstein: Enemy Territory 2.60b compatible client/server (etlegacy mod)
diff --git a/PKGBUILD b/PKGBUILD
index 8f1e3e1b205e..6d87c8a5ea49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Artem 'skybon' Vorotnikov <artem@vorotnikov.me>
-# Contributor: Remy 'spyhawk' Marquis <remy.marquis@gmail.com>
+# Full 64 bit ET:Legacy clients can only connect to ET:Legacy servers running mods providing a 64 bit version.
+# If you want to connect to existing 32 bit only mods, install the cross-compiled "etlegacy32-git" package instead.
+# Other optional deps: 'openal' 'ncurses' 'jansson'
-_gitname=etlegacy
-pkgbase=$_gitname-git
+pkgbase=etlegacy-git
pkgname=('etlegacy-git' 'etlegacy-mod-git')
-pkgver=LATEST
+pkgver=2.73.91.ga1d3419
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://etlegacy.com/"
license=('GPL3')
makedepends=('git' 'cmake' 'zip' 'alsa-lib' 'curl' 'freetype2' 'glew' 'libjpeg-turbo' 'libvorbis' 'lua' 'sdl2')
options=(!strip)
source=('git+https://github.com/etlegacy/etlegacy.git')
sha512sums=('SKIP')
+_gitname=etlegacy
pkgver() {
cd "$srcdir/$_gitname"
@@ -38,14 +39,12 @@ build() {
"-D INSTALL_DEFAULT_BINDIR=bin"
"-D INSTALL_DEFAULT_MODDIR=lib/etlegacy"
)
-
- # arch && cross-compilation
+ # arch
cmakeopts+=(
"-D CMAKE_LIBRARY_PATH=/usr/lib"
"-D CMAKE_INCLUDE_PATH=/usr/include"
"-D CROSS_COMPILE32=0"
)
-
# options
cmakeopts+=(
"-D BUILD_SERVER=1"
@@ -107,8 +106,6 @@ package_etlegacy-git() {
depends=('etlegacy-mod-git' 'alsa-lib' 'curl' 'freetype2' 'gcc-libs' 'glew' 'libjpeg-turbo' 'libvorbis' 'lua' 'sdl2')
provides=('etlegacy')
conflicts=('etlegacy')
- conflicts_x86_64=('etlegacy64-git')
- replaces_x86_64=('etlegacy64-git')
backup=('etc/xdg/etlegacy/etmain/etl_server.cfg'
'etc/xdg/etlegacy/etmain/legacy.cfg'
'etc/xdg/etlegacy/etmain/campaigncycle.cfg'