summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-08-18 13:13:02 +0300
committerArtem Vorotnikov2015-08-18 13:13:02 +0300
commitb44e1007f975200a0a8f1897737793ce6921e41c (patch)
tree8f3c9576479fd42a43027a6f9d231dcac7b085c6
downloadaur-b44e1007f975200a0a8f1897737793ce6921e41c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42b1c0083e12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = etlegacy-omnibot
+ pkgdesc = Wolfenstein: Enemy Territory 2.60b compatible client/server (omni-bot files)
+ pkgver = 0.84.1051
+ pkgrel = 2
+ url = http://omni-bot.invisionzone.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = etlegacy-mod
+ source = http://mirror.etlegacy.com/omnibot/omnibot-linux-latest.tar.gz
+ md5sums = 2d15c58fe8dd3829e16e710f29f695cb
+
+pkgname = etlegacy-omnibot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..188c9e902ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=etlegacy-omnibot
+pkgver=0.84.1051 # etlegacy version is slightly newer than the official 0.84 omnibot release
+pkgrel=2
+pkgdesc="Wolfenstein: Enemy Territory 2.60b compatible client/server (omni-bot files)"
+arch=('i686' 'x86_64')
+url="http://omni-bot.invisionzone.com"
+license=('custom')
+depends=('etlegacy-mod')
+source=('http://mirror.etlegacy.com/omnibot/omnibot-linux-latest.tar.gz')
+md5sums=('2d15c58fe8dd3829e16e710f29f695cb')
+
+package() {
+ # omni-bot
+ mkdir -p $pkgdir/usr/lib/etlegacy/legacy
+ mv omni-bot $pkgdir/usr/lib/etlegacy/legacy
+
+ # writable user config
+ chmod 666 $pkgdir/usr/lib/etlegacy/legacy/omni-bot/et/user/omni-bot.cfg
+}
+
+# vim:set ts=4 sw=2 et: