summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Cromer2016-09-04 16:31:33 -0300
committerChris Cromer2016-09-04 16:31:33 -0300
commit1c5eac5d779c20dcb73b1e488a713f50e899a251 (patch)
treee42a3c56d210e684df61c112be3e26aa9b78f48b
parent2b00eb01e95716719678906b0c006f3fed3c9ad6 (diff)
downloadaur-1c5eac5d779c20dcb73b1e488a713f50e899a251.tar.gz
updated to 3.2
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD78
-rw-r--r--udev-hwdb.hook11
3 files changed, 88 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf2edbcf1a47..ac9fa28cb360 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,46 @@
pkgbase = eudev
- pkgdesc = The userspace dev tools (udev) forked by Gentoo
- pkgver = 3.1.2
- pkgrel = 4
+ pkgver = 3.2
+ pkgrel = 2
url = http://www.gentoo.org/proj/en/eudev/
arch = i686
arch = x86_64
+ groups = base
+ groups = base-openrc
license = GPL
makedepends = gobject-introspection
makedepends = gperf
makedepends = gtk-doc
makedepends = intltool
- depends = glib2
- depends = kbd
- depends = kmod
- depends = hwids
- depends = util-linux
- optdepends = eudev-systemdcompat: makes packages compiled with systemd features run
- optdepends = upower-pm-utils: pm-utils support
- provides = udev=221
- provides = libudev=221
- provides = libudev.so
- conflicts = libudev.so
- options = !makeflags
+ makedepends = kmod
options = !libtool
- backup = etc/udev/udev.conf
- source = https://github.com/gentoo/eudev/archive/v3.1.2.tar.gz
+ options = !staticlibs
+ source = eudev-3.2.tar.gz::https://github.com/gentoo/eudev/archive/v3.2.tar.gz
source = initcpio_hooks
source = initcpio_install
- sha256sums = f8b08fee36f7cf9389dd1dce67a863b717ea54437a96e0921f94e0497eb5dab6
+ source = udev-hwdb.hook
+ sha256sums = 37829d37f4beb7e358ca33abc1ad0907d87f917ce157777aeaeebeacae24efdc
sha256sums = 892ce43218e0a458981bbce451252c8987dc398e60b8de288e7542b8f2409c13
sha256sums = 77dd1fd318b4456409aceb077f060b87944defb07cf39d29ad1968dc6f361875
+ sha256sums = 7432c12205ba58ecb94a417198012fc1739ae107ffd0bf5a6e22dd9bdbf69d76
pkgname = eudev
+ pkgdesc = The userspace dev tools (udev) forked by Gentoo
+ depends = libeudev
+ depends = kbd
+ depends = kmod
+ depends = hwids
+ depends = util-linux
+ optdepends = eudev-systemd: makes packages compiled with systemd features run
+ optdepends = udev-openrc: udev starup scripts for openrc
+ provides = udev=220
+ backup = etc/udev/udev.conf
+
+pkgname = libeudev
+ pkgdesc = eudev client libraries
+ depends = glib2
+ depends = glibc
+ optdepends = libeudev-systemd: systemd client libraries
+ provides = libudev=220
+ provides = libudev.so
+ conflicts = libudev.so
diff --git a/PKGBUILD b/PKGBUILD
index b663b8a364a1..015e88d4eddb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
+# Maintainer: Chris Cromer <chris@cromer.cl>
# Maintainer: artoo <artoo@manjaro.org>
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
# Contributor: Ivailo Monev <xakepa10@gmail.com>
-_udev_ver=221
-_src_uri='http://dev.gentoo.org/~blueness/eudev'
+_udev_ver=220
-pkgname=eudev
-pkgver=3.1.2
-pkgrel=4
-pkgdesc="The userspace dev tools (udev) forked by Gentoo"
+pkgbase=eudev
+pkgname=( 'eudev' 'libeudev')
+pkgver=3.2
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.gentoo.org/proj/en/eudev/"
license=('GPL')
-depends=('glib2' 'kbd' 'kmod' 'hwids' 'util-linux')
-makedepends=('gobject-introspection' 'gperf' 'gtk-doc' 'intltool')
-optdepends=('eudev-systemdcompat: makes packages compiled with systemd features run'
- 'upower-pm-utils: pm-utils support')
-provides=("udev=${_udev_ver}"
- "libudev=${_udev_ver}"
- 'libudev.so')
-conflicts=('libudev.so')
-backup=('etc/udev/udev.conf')
-options=(!makeflags !libtool)
-source=("https://github.com/gentoo/eudev/archive/v${pkgver}.tar.gz"
+makedepends=('gobject-introspection' 'gperf' 'gtk-doc' 'intltool' 'kmod')
+options=('!libtool' '!staticlibs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gentoo/eudev/archive/v${pkgver}.tar.gz"
'initcpio_hooks'
- 'initcpio_install')
-sha256sums=('f8b08fee36f7cf9389dd1dce67a863b717ea54437a96e0921f94e0497eb5dab6'
+ 'initcpio_install'
+ 'udev-hwdb.hook')
+sha256sums=('37829d37f4beb7e358ca33abc1ad0907d87f917ce157777aeaeebeacae24efdc'
'892ce43218e0a458981bbce451252c8987dc398e60b8de288e7542b8f2409c13'
- '77dd1fd318b4456409aceb077f060b87944defb07cf39d29ad1968dc6f361875')
+ '77dd1fd318b4456409aceb077f060b87944defb07cf39d29ad1968dc6f361875'
+ '7432c12205ba58ecb94a417198012fc1739ae107ffd0bf5a6e22dd9bdbf69d76')
+
+prepare(){
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules
+}
+
+groups=('base' 'base-openrc')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
./autogen.sh
./configure \
--prefix=/usr \
@@ -38,8 +39,6 @@ build() {
--sysconfdir=/etc \
--libdir=/usr/lib \
--sbindir=/usr/bin \
- --with-html-dir=/usr/share/doc/${pkgname}-${pkgver}/html \
- --disable-gudev \
--enable-introspection \
--enable-kmod \
--enable-manpages \
@@ -48,16 +47,35 @@ build() {
make
}
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+package_eudev() {
+ pkgdesc="The userspace dev tools (udev) forked by Gentoo"
+ provides=("udev=${_udev_ver}")
+ depends=("libeudev" 'kbd' 'kmod' 'hwids' 'util-linux')
+ optdepends=('eudev-systemd: makes packages compiled with systemd features run'
+ 'udev-openrc: udev starup scripts for openrc')
+ backup=('etc/udev/udev.conf')
+
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
make DESTDIR="${pkgdir}" install
- for i in "${pkgdir}/usr/lib/udev/rules.d/"*.rules; do
- sed -i -e 's#GROUP="dialout"#GROUP="uucp"#g;
- s#GROUP="tape"#GROUP="storage"#g;
- s#GROUP="cdrom"#GROUP="optical"#g' "${i}"
- done
+ rm -rv "$pkgdir"/usr/lib/pkgconfig
+ rm -v "$pkgdir"/usr/include/libudev.h
+ rm -v "$pkgdir"/usr/lib/libudev*.{so*,a}
install -Dm644 "${srcdir}/initcpio_hooks" "${pkgdir}/usr/lib/initcpio/hooks/udev"
install -Dm644 "${srcdir}/initcpio_install" "${pkgdir}/usr/lib/initcpio/install/udev"
+ install -Dm644 "$srcdir/udev-hwdb.hook" "$pkgdir/usr/share/libalpm/hooks/udev-hwdb.hook"
+}
+
+package_libeudev() {
+ pkgdesc="eudev client libraries"
+ depends=('glib2' 'glibc')
+ optdepends=('libeudev-systemd: systemd client libraries')
+ conflicts=('libudev.so')
+ provides=("libudev=${_udev_ver}" 'libudev.so')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make -C src/libudev DESTDIR="$pkgdir" install
}
diff --git a/udev-hwdb.hook b/udev-hwdb.hook
new file mode 100644
index 000000000000..7bc055b4e777
--- /dev/null
+++ b/udev-hwdb.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/udev/hwdb.d/*
+
+[Action]
+Description = Updating udev Hardware Database...
+When = PostTransaction
+Exec = /usr/bin/udevadm hwdb --update