summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2013-09-29 11:30:57 +0400
committerAlexey D2015-07-05 08:55:51 +0300
commit8b9f0caedddc24225fd05ec9c9c7ef734ab68a32 (patch)
tree0a47d5a9b6f96fb7fa8a3866f9cd91d075aa645b
parent4173ba106fe47a12536942d7a1833d39cef18fd6 (diff)
downloadaur-8b9f0caedddc24225fd05ec9c9c7ef734ab68a32.tar.gz
version 20130927-1
-rw-r--r--.SRCINFO6
-rw-r--r--80-net-name-slot.rules5
-rw-r--r--PKGBUILD10
-rwxr-xr-xinitcpio_install4
4 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2ac561cefe6..738ef3eefb94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eudev-git
pkgdesc = The userspace dev tools (udev) forked by Gentoo
- pkgver = 20130914
+ pkgver = 20130927
pkgrel = 1
url = https://github.com/gentoo/eudev
install = eudev-git.install
@@ -41,8 +41,8 @@ pkgbase = eudev-git
source = 80-net-name-slot.rules
md5sums = SKIP
md5sums = e99e9189aa2f6084ac28b8ddf605aeb8
- md5sums = 825af8cce7dd73ed4ce1a8289e3bdad8
- md5sums = 372d60f89f626629005bb755be259a20
+ md5sums = 88849afefcef229b8f79be7bbf05c3a2
+ md5sums = d83a59d647b511b815ee0e8c85dcd54a
pkgname = eudev-git
diff --git a/80-net-name-slot.rules b/80-net-name-slot.rules
index e0990de2d3a8..fdb87a82dee1 100644
--- a/80-net-name-slot.rules
+++ b/80-net-name-slot.rules
@@ -1,7 +1,10 @@
-ACTION=="remove", GOTO="net_name_slot_end"
+ACTION!="add", GOTO="net_name_slot_end"
SUBSYSTEM!="net", GOTO="net_name_slot_end"
NAME!="", GOTO="net_name_slot_end"
+IMPORT{cmdline}="net.ifnames"
+ENV{net.ifnames}=="0", GOTO="net_name_slot_end"
+
#NAME=="", ENV{ID_NET_NAME_ONBOARD}!="", NAME="$env{ID_NET_NAME_ONBOARD}"
#NAME=="", ENV{ID_NET_NAME_SLOT}!="", NAME="$env{ID_NET_NAME_SLOT}"
#NAME=="", ENV{ID_NET_NAME_PATH}!="", NAME="$env{ID_NET_NAME_PATH}"
diff --git a/PKGBUILD b/PKGBUILD
index f754e05bac22..b751c4588932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ivailo Monev <xakepa10@gmail.com>
pkgname='eudev-git'
pkgdesc="The userspace dev tools (udev) forked by Gentoo"
-pkgver=20130914
+pkgver=20130927
pkgrel=1
_udevver=207
provides=("udev=${_udevver}" "systemd=${_udevver}" "libsystemd=${_udevver}" "systemd-tools=${_udevver}")
@@ -24,9 +24,9 @@ source=('git://github.com/gentoo/eudev.git'
options=(!makeflags !libtool)
md5sums=('SKIP'
'e99e9189aa2f6084ac28b8ddf605aeb8'
- '825af8cce7dd73ed4ce1a8289e3bdad8'
- '372d60f89f626629005bb755be259a20')
-_gitname=('eudev')
+ '88849afefcef229b8f79be7bbf05c3a2'
+ 'd83a59d647b511b815ee0e8c85dcd54a')
+_gitname="eudev"
pkgver()
{
@@ -52,7 +52,7 @@ build() {
--libdir=/usr/lib \
--sbindir=/usr/bin \
--with-firmware-path=/usr/lib/firmware/updates:/lib/firmware/updates:/usr/lib/firmware:/lib/firmware \
- --with-modprobe=/sbin/modprobe \
+ --with-modprobe=/usr/bin/modprobe \
--enable-gudev \
--enable-introspection
diff --git a/initcpio_install b/initcpio_install
index b280d8dceb5b..9c1ac6da3efd 100755
--- a/initcpio_install
+++ b/initcpio_install
@@ -5,8 +5,8 @@ build() {
add_binary /usr/bin/udevd
add_binary /usr/bin/udevadm
- for rule in /usr/lib/udev/rules.d/*.rules; do
- add_file "$rule"
+ for rule in 50-udev-default.rules 60-persistent-storage.rules 64-btrfs.rules 80-drivers-modprobe.rules; do
+ add_file "/usr/lib/udev/rules.d/$rule"
done
for tool in ata_id scsi_id; do