summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2018-01-09 14:14:12 +0100
committerMichael Straube2018-01-09 14:14:12 +0100
commit0acf65e33e963cdabb3c8eef2026935746ad925f (patch)
tree3d1a7b7b52f699ce4534093c096e220ad9022fea
parent8b4095ba494a9b6e42d7ea580eff199436270aa3 (diff)
downloadaur-0acf65e33e963cdabb3c8eef2026935746ad925f.tar.gz
Respect LDFLAGS
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--eureka.patch14
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ddce1fdc4d0..606ad9a57df4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eureka
pkgdesc = A map editor for the classic DOOM games
pkgver = 1.21
- pkgrel = 1
+ pkgrel = 2
url = http://eureka-editor.sourceforge.net
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = eureka
source = https://download.sourceforge.net/eureka-editor/eureka-121-source.tar.gz
source = eureka.patch
sha256sums = 39ce6ce40137be3f8391a513adc533a616fc0a8c5e51c4e4f9cc9912fb71f7a8
- sha256sums = 4a4bc8ec5f164b647ac395d3242f44eb2440cb3b79ad55063cbefeda9781149a
+ sha256sums = f2f3f1f7927997a2ddebf1abb477c77d46b7b2c7d7b69fd10f782771eefb176a
pkgname = eureka
diff --git a/PKGBUILD b/PKGBUILD
index 50ceb8a84eb3..08ad6423d41a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=eureka
pkgver=1.21
-pkgrel=1
+pkgrel=2
pkgdesc="A map editor for the classic DOOM games"
arch=('i686' 'x86_64')
url="http://eureka-editor.sourceforge.net"
@@ -13,7 +13,7 @@ depends=('fltk')
source=("https://download.sourceforge.net/eureka-editor/eureka-121-source.tar.gz"
"eureka.patch")
sha256sums=('39ce6ce40137be3f8391a513adc533a616fc0a8c5e51c4e4f9cc9912fb71f7a8'
- '4a4bc8ec5f164b647ac395d3242f44eb2440cb3b79ad55063cbefeda9781149a')
+ 'f2f3f1f7927997a2ddebf1abb477c77d46b7b2c7d7b69fd10f782771eefb176a')
prepare() {
cd $pkgname-$pkgver-source
diff --git a/eureka.patch b/eureka.patch
index 04bfbb0411dd..e3b577d4fc4d 100644
--- a/eureka.patch
+++ b/eureka.patch
@@ -1,5 +1,15 @@
---- eureka-1.21-source-orig/Makefile 2017-01-12 04:40:19.000000000 +0100
-+++ eureka-1.21-source/Makefile 2017-01-12 22:39:23.218923650 +0100
+diff -ru eureka-1.21-source-orig/Makefile eureka-1.21-source/Makefile
+--- eureka-1.21-source-orig/Makefile 2018-01-09 14:05:02.549661357 +0100
++++ eureka-1.21-source/Makefile 2018-01-09 14:06:03.161776098 +0100
+@@ -26,7 +26,7 @@
+ CXXFLAGS=$(OPTIMISE) -Wall -D$(OS) \
+ -D_THREAD_SAFE -D_REENTRANT
+
+-LDFLAGS=-L/usr/X11R6/lib
++LDFLAGS+=-L/usr/X11R6/lib
+
+ LIBS= \
+ -lfltk_images -lfltk_gl -lfltk \
@@ -134,7 +134,8 @@
stripped: $(PROGRAM)
strip $(STRIP_FLAGS) $(PROGRAM)