summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-11-19 23:30:47 +0100
committerMichael Straube2016-11-19 23:30:47 +0100
commit7624712f546cc03f8f5e0f714c0adcd96a087841 (patch)
treee5dc9bfda521b52c94e254ed3b083bd430f5dfe6
parent46d2c45a68a38fdede68117d066d14f1e4677272 (diff)
downloadaur-7624712f546cc03f8f5e0f714c0adcd96a087841.tar.gz
Use prepare() function, cleanup
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
-rw-r--r--eureka.install4
-rw-r--r--makefile.patch21
4 files changed, 51 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ec88c4e5d7b..9a71b0d10786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Jan 29 06:40:18 UTC 2016
pkgbase = eureka
pkgdesc = A map editor for the classic DOOM games
pkgver = 1.11
- pkgrel = 1
- url = http://eureka-editor.sourceforge.net/
- arch = x86_64
+ pkgrel = 2
+ url = http://eureka-editor.sourceforge.net
arch = i686
+ arch = x86_64
license = GPL2
depends = fltk
- depends = libjpeg-turbo
- source = http://download.sourceforge.net/eureka-editor/Eureka/1.07/eureka-111-source.tar.gz
- source = eureka.install
- md5sums = 354f95f286a064ce405de9baacb9771d
- md5sums = 41026f5e9e4d3ba7559da2a8c9b26816
+ source = https://download.sourceforge.net/eureka-editor/eureka-111-source.tar.gz
+ source = makefile.patch
+ sha1sums = 7e19a139e71893a85aff49520b5e9a9e55224ccc
+ sha1sums = d84f90164b8561d673f673255028a0a4c7b63f2a
pkgname = eureka
diff --git a/PKGBUILD b/PKGBUILD
index 84b2aa33e8a6..1915ee9ec005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Michael Straube <michael_straube@web.de>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Valsu [arch(at)hylia.de]
pkgname=eureka
pkgver=1.11
-_pkgver=111
-pkgrel=1
+pkgrel=2
pkgdesc="A map editor for the classic DOOM games"
-url="http://eureka-editor.sourceforge.net/"
-arch=('x86_64' 'i686')
+arch=('i686' 'x86_64')
+url="http://eureka-editor.sourceforge.net"
license=('GPL2')
-depends=('fltk' 'libjpeg-turbo')
-source=("http://download.sourceforge.net/eureka-editor/Eureka/1.07/${pkgname}-${_pkgver}-source.tar.gz"
-"eureka.install")
-md5sums=('354f95f286a064ce405de9baacb9771d'
- '41026f5e9e4d3ba7559da2a8c9b26816')
+depends=('fltk')
+source=("https://download.sourceforge.net/eureka-editor/eureka-111-source.tar.gz"
+ "makefile.patch")
+sha1sums=('7e19a139e71893a85aff49520b5e9a9e55224ccc'
+ 'd84f90164b8561d673f673255028a0a4c7b63f2a')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}-source"
+prepare() {
+ cd $pkgname-$pkgver-source
+
+ patch -p1 -i ../makefile.patch
+}
- sed 's/install: stripped/install:/g' -i Makefile
- sed '/xdg-/d' -i Makefile
+build() {
+ cd $pkgname-$pkgver-source
- make PREFIX=/usr OPTIMISE="${CXXFLAGS}"
+ make PREFIX=/usr OPTIMISE="$CXXFLAGS"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}-source"
+ cd $pkgname-$pkgver-source
- mkdir -p "${pkgdir}/usr/bin"
- make PREFIX="${pkgdir}/usr" install
+ make PREFIX="$pkgdir"/usr install
- install -D -m644 misc/eureka.xpm "${pkgdir}/usr/share/pixmaps/eureka.xpm"
- install -D -m644 misc/eureka.desktop "${pkgdir}/usr/share/applications/eureka.desktop"
- install -D -m644 misc/eureka.6 "${pkgdir}/usr/share/man/man6/eureka.6"
+ install -Dm644 misc/eureka.xpm "$pkgdir"/usr/share/pixmaps/eureka.xpm
+ install -Dm644 misc/eureka.desktop "$pkgdir"/usr/share/applications/eureka.desktop
+ install -Dm644 misc/eureka.6 "$pkgdir"/usr/share/man/man6/eureka.6
}
# vim:set ts=2 sw=2 et:
-
-
diff --git a/eureka.install b/eureka.install
deleted file mode 100644
index 96db59ecb4eb..000000000000
--- a/eureka.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
-echo "You will need either Ultimate Doom or Doom 2 wad"
-echo "to work with Eureka."
-} \ No newline at end of file
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..95ae35ebd0fc
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2016-11-19 21:42:31.154905909 +0100
++++ b/Makefile 2016-11-19 21:43:18.114067788 +0100
+@@ -156,7 +156,8 @@
+ stripped: $(PROGRAM)
+ strip $(STRIP_FLAGS) $(PROGRAM)
+
+-install: stripped
++install:
++ install -d $(PREFIX)/bin
+ install -o root -m 755 $(PROGRAM) $(PREFIX)/bin/
+ install -d $(INSTALL_DIR)/games
+ install -d $(INSTALL_DIR)/common
+@@ -169,8 +170,6 @@
+ install -o root -m 644 common/*.* $(INSTALL_DIR)/common
+ install -o root -m 644 ports/*.* $(INSTALL_DIR)/ports
+ # install -o root -m 644 mods/*.* $(INSTALL_DIR)/mods
+- xdg-desktop-menu install --novendor misc/eureka.desktop
+- xdg-icon-resource install --novendor --size 32 misc/eureka.xpm
+
+ uninstall:
+ rm -v $(PREFIX)/bin/$(PROGRAM)