summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-01-12 22:56:09 +0100
committerMichael Straube2017-01-12 22:56:09 +0100
commit8b4095ba494a9b6e42d7ea580eff199436270aa3 (patch)
tree00820a1b3048378b57b7504103d5e3d66f8d3d19
parentb65b961c32aa130b6068d6be930a2fb65cf5a735 (diff)
downloadaur-8b4095ba494a9b6e42d7ea580eff199436270aa3.tar.gz
Version 1.21
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--eureka.patch (renamed from makefile.patch)10
3 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4eabe5f3a82..3ddce1fdc4d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = eureka
pkgdesc = A map editor for the classic DOOM games
- pkgver = 1.11
- pkgrel = 3
+ pkgver = 1.21
+ pkgrel = 1
url = http://eureka-editor.sourceforge.net
arch = i686
arch = x86_64
license = GPL
depends = fltk
- source = https://download.sourceforge.net/eureka-editor/eureka-111-source.tar.gz
- source = makefile.patch
- sha256sums = c29988b7e974ce61e7744ace8f768db48af926b453e604016faafc8b9e479735
- sha256sums = 925edf9d4f9a52776df0e011e1c9fd1b978adb3043f4d8d56ae4caa9c558d71b
+ source = https://download.sourceforge.net/eureka-editor/eureka-121-source.tar.gz
+ source = eureka.patch
+ sha256sums = 39ce6ce40137be3f8391a513adc533a616fc0a8c5e51c4e4f9cc9912fb71f7a8
+ sha256sums = 4a4bc8ec5f164b647ac395d3242f44eb2440cb3b79ad55063cbefeda9781149a
pkgname = eureka
diff --git a/PKGBUILD b/PKGBUILD
index 269a50d74379..50ceb8a84eb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
# Contributor: Valsu [arch(at)hylia.de]
pkgname=eureka
-pkgver=1.11
-pkgrel=3
+pkgver=1.21
+pkgrel=1
pkgdesc="A map editor for the classic DOOM games"
arch=('i686' 'x86_64')
url="http://eureka-editor.sourceforge.net"
license=('GPL')
depends=('fltk')
-source=("https://download.sourceforge.net/eureka-editor/eureka-111-source.tar.gz"
- "makefile.patch")
-sha256sums=('c29988b7e974ce61e7744ace8f768db48af926b453e604016faafc8b9e479735'
- '925edf9d4f9a52776df0e011e1c9fd1b978adb3043f4d8d56ae4caa9c558d71b')
+source=("https://download.sourceforge.net/eureka-editor/eureka-121-source.tar.gz"
+ "eureka.patch")
+sha256sums=('39ce6ce40137be3f8391a513adc533a616fc0a8c5e51c4e4f9cc9912fb71f7a8'
+ '4a4bc8ec5f164b647ac395d3242f44eb2440cb3b79ad55063cbefeda9781149a')
prepare() {
cd $pkgname-$pkgver-source
- patch -p1 -i ../makefile.patch
+ # patch Makefile
+ patch -p1 -i ../eureka.patch
}
build() {
@@ -36,5 +37,3 @@ package() {
install -Dm644 misc/eureka.desktop "$pkgdir"/usr/share/applications/eureka.desktop
install -Dm644 misc/eureka.6 "$pkgdir"/usr/share/man/man6/eureka.6
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/makefile.patch b/eureka.patch
index 95ae35ebd0fc..04bfbb0411dd 100644
--- a/makefile.patch
+++ b/eureka.patch
@@ -1,6 +1,6 @@
---- a/Makefile 2016-11-19 21:42:31.154905909 +0100
-+++ b/Makefile 2016-11-19 21:43:18.114067788 +0100
-@@ -156,7 +156,8 @@
+--- eureka-1.21-source-orig/Makefile 2017-01-12 04:40:19.000000000 +0100
++++ eureka-1.21-source/Makefile 2017-01-12 22:39:23.218923650 +0100
+@@ -134,7 +134,8 @@
stripped: $(PROGRAM)
strip $(STRIP_FLAGS) $(PROGRAM)
@@ -10,10 +10,10 @@
install -o root -m 755 $(PROGRAM) $(PREFIX)/bin/
install -d $(INSTALL_DIR)/games
install -d $(INSTALL_DIR)/common
-@@ -169,8 +170,6 @@
+@@ -147,8 +148,6 @@
+ install -o root -m 644 games/*.* $(INSTALL_DIR)/games
install -o root -m 644 common/*.* $(INSTALL_DIR)/common
install -o root -m 644 ports/*.* $(INSTALL_DIR)/ports
- # install -o root -m 644 mods/*.* $(INSTALL_DIR)/mods
- xdg-desktop-menu install --novendor misc/eureka.desktop
- xdg-icon-resource install --novendor --size 32 misc/eureka.xpm