summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-02-08 13:21:23 -0500
committerfrealgagu2020-02-08 13:21:23 -0500
commit9957fc8c95dd4f6cf4b77579d1d9b8a857a7be78 (patch)
treeb09fec883142a4d3dc8e4cd3f1a8c11df2d4e12d
parent3aefc390c4778d4c020d62ab9da8e017627c77b1 (diff)
downloadaur-9957fc8c95dd4f6cf4b77579d1d9b8a857a7be78.tar.gz
Upgrading to version 1.27
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
-rw-r--r--eureka.patch10
4 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0636f4f66636..cd76703be7b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = eureka
pkgdesc = A map editor for the classic DOOM games
- pkgver = 1.24
- pkgrel = 2
+ pkgver = 1.27
+ pkgrel = 1
url = http://eureka-editor.sourceforge.net/
arch = i686
arch = x86_64
license = GPL2
depends = fltk
- source = https://download.sourceforge.net/eureka-editor/eureka-124-source.tar.gz
+ source = https://download.sourceforge.net/eureka-editor/eureka-127-source.tar.gz
source = eureka.patch
- md5sums = 690d64ea32b2b4bbe081e2c079936c1f
- md5sums = d54b67edf77c3f9c14a30f5b17862cbb
- sha1sums = 78754c63bda8296627b185f62a6ec57e5c618a15
- sha1sums = dd0bdca256d4225b80addc9eb5ee333fc495b05a
- sha256sums = 3bb5a272b53a275f09c7fa5a29f417e257a7dc89d6689de45055a71fad6c91f4
- sha256sums = 4ae5f645ffa9fe422a3a3f3c2892f2935815bf4d77d82481992f06ff3ac72946
+ md5sums = de518200b008f6bceda5bce66da47d5c
+ md5sums = fd239308e1594262d26692b54ab083a3
+ sha1sums = 296ac2bef8bcb4af5587097a8f3c0cf1ca8856bf
+ sha1sums = 2c6194833e886b3a2d968271d7a650b8b12b4231
+ sha256sums = af77b887ca29353fe3d9fba5436e57f8beb2426fd60f26e3d14b2271d2d14ff3
+ sha256sums = b4dfc71a004be7a08877005d71893488a92dbc17e4b1e13b80b75998d2950e69
pkgname = eureka
diff --git a/.gitignore b/.gitignore
index bda0b66f762e..0f8a4078dbb3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+eureka-*.pkg.tar.zst
eureka-*.pkg.tar.xz
eureka-*.tar.gz
eureka-*.log
diff --git a/PKGBUILD b/PKGBUILD
index 00ef20bc5fb5..88245efc4f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,26 @@
# Contributor: Valsu [arch(at)hylia.de]
pkgname=eureka
-pkgver=1.24
-pkgrel=2
+pkgver=1.27
+pkgrel=1
pkgdesc="A map editor for the classic DOOM games"
arch=("i686" "x86_64")
url="http://${pkgname}-editor.sourceforge.net/"
license=("GPL2")
depends=("fltk")
-source=(
- "https://download.sourceforge.net/${pkgname}-editor/${pkgname}-${pkgver/\./}-source.tar.gz"
- "${pkgname}.patch"
-)
+source=("https://download.sourceforge.net/${pkgname}-editor/${pkgname}-${pkgver/\./}-source.tar.gz"
+ "${pkgname}.patch")
md5sums=(
- "690d64ea32b2b4bbe081e2c079936c1f"
- "d54b67edf77c3f9c14a30f5b17862cbb"
+ "de518200b008f6bceda5bce66da47d5c"
+ "fd239308e1594262d26692b54ab083a3"
)
sha1sums=(
- "78754c63bda8296627b185f62a6ec57e5c618a15"
- "dd0bdca256d4225b80addc9eb5ee333fc495b05a"
+ "296ac2bef8bcb4af5587097a8f3c0cf1ca8856bf"
+ "2c6194833e886b3a2d968271d7a650b8b12b4231"
)
sha256sums=(
- "3bb5a272b53a275f09c7fa5a29f417e257a7dc89d6689de45055a71fad6c91f4"
- "4ae5f645ffa9fe422a3a3f3c2892f2935815bf4d77d82481992f06ff3ac72946"
+ "af77b887ca29353fe3d9fba5436e57f8beb2426fd60f26e3d14b2271d2d14ff3"
+ "b4dfc71a004be7a08877005d71893488a92dbc17e4b1e13b80b75998d2950e69"
)
prepare() {
diff --git a/eureka.patch b/eureka.patch
index a662405fb552..6aa7c07f409c 100644
--- a/eureka.patch
+++ b/eureka.patch
@@ -1,14 +1,12 @@
diff --git a/Makefile b/Makefile
-index 17088c5..234755b 100644
+index ebbd53a..9c1762e 100644
--- a/Makefile
+++ b/Makefile
-@@ -140,7 +140,8 @@ stripped: all
-
+@@ -151,6 +151,7 @@ stripped: all
INSTALL_DIR=$(DESTDIR)$(PREFIX)/share/eureka
--install: stripped
-+install:
+ install: all
+ install -d $(PREFIX)/bin
- install -o root -m 755 $(PROGRAM) $(DESTDIR)$(PREFIX)/bin/
+ install -m 755 $(PROGRAM) $(DESTDIR)$(PREFIX)/bin/
install -d $(INSTALL_DIR)/games
install -d $(INSTALL_DIR)/common