summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-21 14:04:23 +0800
committerzxp198210052023-12-21 14:04:23 +0800
commit14f621d29987bb6ab2a33dab75b3ed3ae6c40f61 (patch)
treeb957fa33e75e41e7d6de4dd8726be0242e42ac70
parent8b1ffd02eb261e3fb8f1b1d409364679ae52121a (diff)
downloadaur-14f621d29987bb6ab2a33dab75b3ed3ae6c40f61.tar.gz
update to 2023.12.19
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--eusoft-eshelper.sh11
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e851b4bf28c..4374d367a095 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eusoft-eshelper-bin
pkgdesc = 西班牙语助手,权威的西班牙语词典软件,西班牙语学习者必备的工具.支持学习笔记、生词本多平台同步,让你随时随地学西班牙语.
- pkgver = 2023.11.07
+ pkgver = 2023.12.19
pkgrel = 1
url = https://www.esdict.cn/
arch = x86_64
@@ -62,9 +62,11 @@ pkgbase = eusoft-eshelper-bin
conflicts = eusoft-eshelper
conflicts = eshelper
options = !strip
- source = eusoft-eshelper-2023.11.07.deb::https://www.eudic.net/download/eshelper.deb?v=2023-11-07
+ source = eusoft-eshelper-2023.12.19.deb::https://www.eudic.net/download/eshelper.deb?v=2023-12-19
source = LICENSE.html
- sha256sums = 8a17ba97d1557e191152489de062c088f9b00d7c7508f0dabc5e9492df19c7d7
+ source = eusoft-eshelper.sh
+ sha256sums = 59af3b48c1cda58220e303c479d8244257fb2d7c7be7d229b83f3e8dc23ee358
sha256sums = bb199c3faf0e1155a5bc43512e1898e6604034a67d9e2f4d16840b3b359cc432
+ sha256sums = e45be7ca2043991bbfea6c9a83e9a324fba6058fa575d53a071274fc824b07fc
pkgname = eusoft-eshelper-bin
diff --git a/PKGBUILD b/PKGBUILD
index bdf5f0cd363a..c9aba63cb5b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
_pkgname=eshelper
pkgname="eusoft-${_pkgname}-bin"
-pkgver=2023.11.07
+pkgver=2023.12.19
pkgrel=1
pkgdesc="西班牙语助手,权威的西班牙语词典软件,西班牙语学习者必备的工具.支持学习笔记、生词本多平台同步,让你随时随地学西班牙语."
arch=('x86_64')
@@ -71,19 +71,23 @@ depends=(
source=(
"${pkgname%-bin}-${pkgver}.deb::https://www.eudic.net/download/${_pkgname}.deb?v=${pkgver//./-}"
"LICENSE.html"
+ "${pkgname%-bin}.sh"
)
-sha256sums=('8a17ba97d1557e191152489de062c088f9b00d7c7508f0dabc5e9492df19c7d7'
- 'bb199c3faf0e1155a5bc43512e1898e6604034a67d9e2f4d16840b3b359cc432')
+sha256sums=('59af3b48c1cda58220e303c479d8244257fb2d7c7be7d229b83f3e8dc23ee358'
+ 'bb199c3faf0e1155a5bc43512e1898e6604034a67d9e2f4d16840b3b359cc432'
+ 'e45be7ca2043991bbfea6c9a83e9a324fba6058fa575d53a071274fc824b07fc')
build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|${_pkgname}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/usr/share/${pkgname%-bin}/AppRun|${pkgname%-bin}|g;s|com.eusoft.${_pkgname}|${pkgname%-bin}|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
- sed "s|usr/share|opt|g" -i "${srcdir}/usr/share/${pkgname%-bin}/AppRun"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt"
cp -r "${srcdir}/usr/share/${pkgname%-bin}" "${pkgdir}/opt"
- ln -sf "/opt/${pkgname%-bin}/AppRun" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/pixmaps/com.eusoft.${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/eusoft-eshelper.sh b/eusoft-eshelper.sh
new file mode 100644
index 000000000000..c4bbd9d7f868
--- /dev/null
+++ b/eusoft-eshelper.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+set -e
+_APPDIR="/opt/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export GST_PLUGIN_SYSTEM_PATH="${_APPDIR}/gstreamer-1.0:${GST_PLUGIN_SYSTEM_PATH}"
+export GST_PLUGIN_PATH="${_APPDIR}/gstreamer-1.0:${GST_PLUGIN_SYSTEM_PATH}"
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@"
+exit \ No newline at end of file