summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 12:39:00 +0800
committerzxp198210052024-01-29 12:39:00 +0800
commitac34d13d546235c75afbd285e9679eedd13f46a3 (patch)
treee8baa767249da45ddb77e8ffb5e48ad6fa70327b
parented6832581341610a66211bdf6e3cb2a3fc7cea37 (diff)
downloadaur-ac34d13d546235c75afbd285e9679eedd13f46a3.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--eusoft-ting-es.sh9
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4e87e91836d..c46c973332a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = eusoft-ting-es-bin
pkgdesc = 听力统计、笔记同步、语音高亮跟随,让您轻松愉快学西班牙语
pkgver = 9.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.esdict.cn/ting
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = hicolor-icon-theme
depends = electron13
conflicts = eusoft-ting-es
@@ -15,6 +15,6 @@ pkgbase = eusoft-ting-es-bin
source = eusoft-ting-es.sh
sha256sums = 73e57df6718460a282ec4bd3d6aea59f78d6097b829b8516f8ab7075e81e981f
sha256sums = bb199c3faf0e1155a5bc43512e1898e6604034a67d9e2f4d16840b3b359cc432
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = eusoft-ting-es-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4229d54c61b4..c19031f2d2f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ pkgname="eusoft-${_appname//_/-}-bin"
_zhname="每日西语听力"
pkgver=9.7.0
_electronversion=13
-pkgrel=2
+pkgrel=3
pkgdesc="听力统计、笔记同步、语音高亮跟随,让您轻松愉快学西班牙语"
arch=('x86_64')
url="https://www.esdict.cn/ting"
-license=('custom')
+license=('LicenseRef-custom')
conflicts=(
"${pkgname%-bin}"
"eudic-${_appname//_/-}"
@@ -25,7 +25,7 @@ source=(
)
sha256sums=('73e57df6718460a282ec4bd3d6aea59f78d6097b829b8516f8ab7075e81e981f'
'bb199c3faf0e1155a5bc43512e1898e6604034a67d9e2f4d16840b3b359cc432'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/eusoft-ting-es.sh b/eusoft-ting-es.sh
index c77c53567639..0d20cddc70ca 100644
--- a/eusoft-ting-es.sh
+++ b/eusoft-ting-es.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file