summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 13:34:17 +0800
committerzxp198210052024-01-29 13:34:17 +0800
commit6011b5bb2720581221e3c1ec2bdd34acf189f9ed (patch)
tree3b277e27f3bf9bb46dde5f2c2fb0d2c4c1ee890b
parent3fd0e6c0d773642bb69fc2d2af9d9e23aca57c9e (diff)
downloadaur-6011b5bb2720581221e3c1ec2bdd34acf189f9ed.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--eusoft-ting-fr.sh9
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 198dac65d23f..ff2552dccc3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = eusoft-ting-fr-bin
pkgdesc = 听力统计、笔记同步、语音高亮跟随,让您轻松愉快学法语
pkgver = 9.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.frdic.com/ting
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = hicolor-icon-theme
depends = electron13
conflicts = eusoft-ting-fr
@@ -15,6 +15,6 @@ pkgbase = eusoft-ting-fr-bin
source = eusoft-ting-fr.sh
sha256sums = efbf72d55838f72fe4992330092473416476bb32ab6a0d03135aff64f99e74c9
sha256sums = 69031e95591a339c4cd9c01547494e23196cea6438608f1f951b493ea8fca54f
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = eusoft-ting-fr-bin
diff --git a/PKGBUILD b/PKGBUILD
index 110c1a866e2f..e95f9efb2771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ pkgname="eusoft-${_pkgname//_/-}-bin"
_zhsname="每日法语听力"
pkgver=9.7.0
_electronversion=13
-pkgrel=2
+pkgrel=3
pkgdesc="听力统计、笔记同步、语音高亮跟随,让您轻松愉快学法语"
arch=('x86_64')
url="https://www.frdic.com/ting"
-license=('custom')
+license=('LicenseRef-custom')
conflicts=("${pkgname%-bin}" "eudic-${_pkgname}" "${_pkgname}")
depends=(
'hicolor-icon-theme'
@@ -21,7 +21,7 @@ source=(
)
sha256sums=('efbf72d55838f72fe4992330092473416476bb32ab6a0d03135aff64f99e74c9'
'69031e95591a339c4cd9c01547494e23196cea6438608f1f951b493ea8fca54f'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/eusoft-ting-fr.sh b/eusoft-ting-fr.sh
index c77c53567639..0d20cddc70ca 100644
--- a/eusoft-ting-fr.sh
+++ b/eusoft-ting-fr.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file