summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2021-10-19 15:21:31 +0300
committerYigit Sever2021-10-19 15:21:31 +0300
commit2826bf89de32ca30f79214b9268298abe23254f9 (patch)
tree07e571904a3a75c1e309bcd620ef1bbc3dcbf019
downloadaur-2826bf89de32ca30f79214b9268298abe23254f9.tar.gz
Initial commit v1.5.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44c8739bc511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = euterpe
+ pkgdesc = Self-hosted music streaming server with RESTful API and Web interface
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/ironsmile/euterpe
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ depends = taglib
+ depends = icu
+ source = euterpe-1.5.1.tar.gz::https://github.com/ironsmile/euterpe/archive/v1.5.1.tar.gz
+ sha256sums = f3b1ef13b2b64d40255a01ff954c409a1b8c22df7f75a1634185ac79219edb04
+
+pkgname = euterpe
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..024a7a25dc2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+
+pkgname=euterpe
+pkgver=1.5.1
+pkgrel=1
+pkgdesc='Self-hosted music streaming server with RESTful API and Web interface'
+arch=('x86_64')
+url="https://github.com/ironsmile/$pkgname"
+license=('GPL')
+depends=('taglib' 'icu')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('f3b1ef13b2b64d40255a01ff954c409a1b8c22df7f75a1634185ac79219edb04')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}