summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Wawrzyniak2019-02-20 08:32:53 -0500
committerMichael Wawrzyniak2019-02-20 08:32:53 -0500
commit0c9239add087706ce54516073c716224b992bf09 (patch)
tree6784c03e16136834bd04a5bf390dc34a239e238c
parent432d29bbfafebcf62be0d5930c6f87c16ac6fa12 (diff)
downloadaur-0c9239add087706ce54516073c716224b992bf09.tar.gz
Update to EVDI v1.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--evdi.Changelog6
-rw-r--r--force_output.patch13
4 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d10ddcf2c38..9ce7aacb8776 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = evdi
pkgdesc = A Linux® kernel module that enables management of multiple screens.
- pkgver = 1.5.1
- pkgrel = 2
+ pkgver = 1.6.0
+ pkgrel = 1
url = https://github.com/DisplayLink/evdi
install = evdi.install
changelog = evdi.Changelog
@@ -10,11 +10,9 @@ pkgbase = evdi
license = GPL
depends = dkms
depends = libdrm
- source = evdi-1.5.1-2.tar.gz::https://github.com/DisplayLink/evdi/archive/v1.5.1.tar.gz
- source = force_output.patch
+ source = evdi-1.6.0-1.tar.gz::https://github.com/DisplayLink/evdi/archive/v1.6.0.tar.gz
source = relro.patch
- md5sums = 20a69bf61aef388019afb283bb03ea29
- md5sums = 8ebc776d731166661106b1fb3eeb306c
+ md5sums = e59f2372e5aa5719da9995f09725c3c7
md5sums = 05e64dd295a66c030139d0c8f6f7013b
pkgname = evdi
diff --git a/PKGBUILD b/PKGBUILD
index a13b19a09765..baa2d7742a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: PlusMinus
pkgname=evdi
-pkgver=1.5.1
-pkgrel=2
+pkgver=1.6.0
+pkgrel=1
pkgdesc="A Linux® kernel module that enables management of multiple screens."
arch=('i686' 'x86_64')
url="https://github.com/DisplayLink/evdi"
@@ -20,12 +20,11 @@ options=()
install=$pkgname.install
changelog=$pkgname.Changelog
source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/v$pkgver.tar.gz
- force_output.patch
relro.patch)
noextract=()
-md5sums=('20a69bf61aef388019afb283bb03ea29'
- '8ebc776d731166661106b1fb3eeb306c'
+md5sums=('e59f2372e5aa5719da9995f09725c3c7'
'05e64dd295a66c030139d0c8f6f7013b')
+
prepare() {
cd "$pkgname-$pkgver"
local src
diff --git a/evdi.Changelog b/evdi.Changelog
index 90e16ae24cca..af909e83fcd2 100644
--- a/evdi.Changelog
+++ b/evdi.Changelog
@@ -1,3 +1,9 @@
+v1.6.0
+EVDI driver used in DisplayLink Ubuntu Software v5.1
+- shift towards 'atomic modesetting'
+- add support for 4.19 and 4.20 kernels
+- drop support for kernels older than 4.2
+
v1.5.1-2
- Removed FBINFO_CAN_FORCE_OUTPUT (breaks 4.20 / apparently never worked right)
(https://github.com/torvalds/linux/commit/04cfcc7ab358e331b32cabde1e853a125f3f8735#diff-43768cc89c01c730cb119634b42dfa81)
diff --git a/force_output.patch b/force_output.patch
deleted file mode 100644
index ebdd1ae54ce7..000000000000
--- a/force_output.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/module/evdi_fb.c b/module/evdi_fb.c
-index af88ea1..52e4af6 100644
---- a/module/evdi_fb.c
-+++ b/module/evdi_fb.c
-@@ -367,7 +367,7 @@ static int evdifb_create(struct drm_fb_helper *helper,
- info->fix.smem_len = size;
- info->fix.smem_start = (unsigned long)ufbdev->ufb.obj->vmapping;
-
-- info->flags = FBINFO_DEFAULT | FBINFO_CAN_FORCE_OUTPUT;
-+ info->flags = FBINFO_DEFAULT;
- info->fbops = &evdifb_ops;
- #if KERNEL_VERSION(4, 11, 0) > LINUX_VERSION_CODE
- drm_fb_helper_fill_fix(info, fb->pitches[0], fb->depth);